summaryrefslogtreecommitdiff
path: root/package/kompexsqlite
diff options
context:
space:
mode:
authorMax Filippov <jcmvbkbc@gmail.com>2015-09-22 10:14:58 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-09-25 09:43:05 +0200
commit6302ecc33fb0b01688a16ac3336cf50531f395cd (patch)
tree7a409105f5df29ccf3468cd6dfc702dce7369daa /package/kompexsqlite
parent0ce9b533e300c71bfa4d7cd77d33e5c07b0a2c7f (diff)
kompexsqlite: don't overwrite CFLAGS and CXXFLAGS in makefiles
Fixes: http://autobuild.buildroot.net/results/68c1cd7ce7889cf8bad8354e8d7b04e912885cb7 Signed-off-by: Max Filippov <jcmvbkbc@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/kompexsqlite')
-rw-r--r--package/kompexsqlite/0002-append-to-cflags-and-cxxflags.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/package/kompexsqlite/0002-append-to-cflags-and-cxxflags.patch b/package/kompexsqlite/0002-append-to-cflags-and-cxxflags.patch
new file mode 100644
index 000000000..abd0dc0fd
--- /dev/null
+++ b/package/kompexsqlite/0002-append-to-cflags-and-cxxflags.patch
@@ -0,0 +1,49 @@
+From 3eb064ffa9b43fb5f245b8abda48a1c152a6f2d7 Mon Sep 17 00:00:00 2001
+From: me <noemail@nowhere.com>
+Date: Thu, 20 Nov 2014 14:37:34 -0700
+Subject: [PATCH] Append to CFLAGS and CXXFLAGS as setup by ./configure. This
+ can allow users to Customize the SQLite build process with compile time
+ #defines rather than altering the sources.
+
+Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
+---
+Backported from: 3eb064ffa9b43fb5f245b8abda48a1c152a6f2d7
+
+ Makefile-shared.mk | 4 ++--
+ Makefile-static.mk | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile-shared.mk b/Makefile-shared.mk
+index b2a4920..d15ce3c 100644
+--- a/Makefile-shared.mk
++++ b/Makefile-shared.mk
+@@ -12,10 +12,10 @@ OBJS= \
+ ${objsdir}/sqlite3.o
+
+ # C Compiler Flags
+-CFLAGS= -fPIC -MMD -MP
++CFLAGS+= -fPIC -MMD -MP
+
+ # CC Compiler Flags
+-CPPFLAGS= -DKOMPEX_SQLITEWRAPPER_EXPORT -DKOMPEX_SQLITEWRAPPER_DYN -fPIC -MMD -MP -I${includedir}
++CPPFLAGS+= -DKOMPEX_SQLITEWRAPPER_EXPORT -DKOMPEX_SQLITEWRAPPER_DYN -fPIC -MMD -MP -I${includedir}
+
+ # Link Libraries and Options
+ LDLIBSOPTIONS= -shared -fPIC
+diff --git a/Makefile-static.mk b/Makefile-static.mk
+index 429a4ff..0678681 100644
+--- a/Makefile-static.mk
++++ b/Makefile-static.mk
+@@ -12,10 +12,10 @@ OBJS= \
+ ${objsdir}/sqlite3.o
+
+ # C Compiler Flags
+-CFLAGS= -MMD -MP
++CFLAGS+= -MMD -MP
+
+ # CC Compiler Flags
+-CPPFLAGS= -I${includedir} -MMD -MP
++CPPFLAGS+= -I${includedir} -MMD -MP
+
+ # Link Libraries and Options
+ LDLIBSOPTIONS=