summaryrefslogtreecommitdiff
path: root/package/kyua
diff options
context:
space:
mode:
authorSebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com>2015-06-11 18:51:33 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-12 21:59:03 +0200
commit315e92c6920cfb4b19d727f58810aea0cf8072e5 (patch)
tree0fd8ac45251191309c3c9f5dc5438ef467180cbf /package/kyua
parent7c8744a2095a46b86f9b00a6346bba108036fe58 (diff)
kyua: new package
Kyua is a testing framework for infrastructure software, originally designed to equip BSD-based operating systems with a test suite. This means that Kyua is lightweight and simple, and that Kyua integrates well with various build systems and continuous integration frameworks. https://github.com/jmmv/kyua [Thomas: fix typo in hash file.] Signed-off-by: Sebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/kyua')
-rw-r--r--package/kyua/Config.in20
-rw-r--r--package/kyua/kyua.hash2
-rw-r--r--package/kyua/kyua.mk27
3 files changed, 49 insertions, 0 deletions
diff --git a/package/kyua/Config.in b/package/kyua/Config.in
new file mode 100644
index 000000000..e1bcd487b
--- /dev/null
+++ b/package/kyua/Config.in
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_KYUA
+ bool "kyua"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_PACKAGE_HAS_LUAINTERPRETER # lutok
+ depends on !BR2_PACKAGE_LUAJIT # lutok
+ select BR2_PACKAGE_ATF
+ select BR2_PACKAGE_LUTOK
+ select BR2_PACKAGE_SQLITE
+ help
+ Kyua is a testing framework for infrastructure software,
+ originally designed to equip BSD-based operating systems
+ with a test suite. This means that Kyua is lightweight
+ and simple, and that Kyua integrates well with various build
+ systems and continuous integration frameworks.
+
+ https://github.com/jmmv/kyua
+
+comment "kyua needs a toolchain w/ C++ and full Lua"
+ depends on !BR2_INSTALL_LIBSTDCPP || BR2_PACKAGE_LUAJIT
+ depends on BR2_PACKAGE_HAS_LUAINTERPRETER
diff --git a/package/kyua/kyua.hash b/package/kyua/kyua.hash
new file mode 100644
index 000000000..298d0d85c
--- /dev/null
+++ b/package/kyua/kyua.hash
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 2b8b64a458b642df75086eeb73e8073d105b8d9cff04c9b1a905b68bc8502560 kyua-0.11.tar.gz
diff --git a/package/kyua/kyua.mk b/package/kyua/kyua.mk
new file mode 100644
index 000000000..c75a09fbc
--- /dev/null
+++ b/package/kyua/kyua.mk
@@ -0,0 +1,27 @@
+################################################################################
+#
+# kyua
+#
+################################################################################
+
+KYUA_VERSION = 0.11
+KYUA_SITE = https://github.com/jmmv/kyua/releases/download/kyua-$(KYUA_VERSION)
+KYUA_DEPENDENCIES = host-pkgconf atf lutok sqlite
+KYUA_CONF_OPTS = --without-doxygen --without-atf
+KYUA_LICENSE = BSD-3c
+KYUA_LICENSE_FILES = COPYING
+KYUA_CONF_ENV = \
+ kyua_cv_attribute_noreturn=yes \
+ kyua_cv_getcwd_dyn=yes \
+ kyua_cv_lchmod_works=no \
+ kyua_cv_getopt_gnu=yes \
+ kyua_cv_getopt_optind_reset_value=0 \
+ kyua_cv_signals_lastno=15
+
+define KYUA_INSTALL_CONFIG
+ $(INSTALL) -D -m 644 $(@D)/examples/kyua.conf $(TARGET_DIR)/etc/kyua/kyua.conf
+endef
+
+KYUA_POST_INSTALL_HOOKS += KYUA_INSTALL_CONFIG
+
+$(eval $(autotools-package))