summaryrefslogtreecommitdiff
path: root/package/lame
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2013-08-30 11:05:57 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-08 21:41:39 +0200
commitadf6511013b8921d6856f5dc0e053cdd27891244 (patch)
tree14f1ba25f8ae138743e3f3954b85883c636714d8 /package/lame
parentbafa8fcc6ce90553843b5c24e68de57c40f94abe (diff)
Remove multimedia subdirectory
Unless it was a group of sub-packages, packages was never regrouped by category. multimedia/ was an exception to this rule. This patch move packages/multimedia/ sub-directories to packages/. It keeps two subdirectories for gstream 0.10 and gstreamer 1.X. Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/lame')
-rw-r--r--package/lame/Config.in6
-rw-r--r--package/lame/lame.mk35
2 files changed, 41 insertions, 0 deletions
diff --git a/package/lame/Config.in b/package/lame/Config.in
new file mode 100644
index 000000000..2b144a053
--- /dev/null
+++ b/package/lame/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LAME
+ bool "lame"
+ help
+ LAME is a high quality MPEG Audio Layer III (MP3) encoder.
+
+ http://lame.sourceforge.net/
diff --git a/package/lame/lame.mk b/package/lame/lame.mk
new file mode 100644
index 000000000..38a39a3d0
--- /dev/null
+++ b/package/lame/lame.mk
@@ -0,0 +1,35 @@
+################################################################################
+#
+# lame
+#
+################################################################################
+
+LAME_VERSION_MAJOR = 3.99
+LAME_VERSION_MINOR = 5
+LAME_VERSION = $(LAME_VERSION_MAJOR).$(LAME_VERSION_MINOR)
+LAME_SITE = http://downloads.sourceforge.net/project/lame/lame/$(LAME_VERSION_MAJOR)
+LAME_DEPENDENCIES = host-pkgconf
+LAME_INSTALL_STAGING = YES
+LAME_CONF_ENV = GTK_CONFIG=/bin/false
+LAME_CONF_OPT = --enable-dynamic-frontends
+LAME_LICENSE = LGPLv2+
+LAME_LICENSE_FILES = COPYING
+
+ifeq ($(BR2_PACKAGE_LIBSNDFILE),y)
+LAME_DEPENDENCIES += libsndfile
+LAME_CONF_OPT += --with-fileio=sndfile
+endif
+
+ifeq ($(BR2_PACKAGE_NCURSES),y)
+LAME_DEPENDENCIES += ncurses
+endif
+
+ifeq ($(BR2_ENDIAN),"BIG")
+define LAME_BIGENDIAN_ARCH
+ echo "#define WORDS_BIGENDIAN 1" >>$(@D)/config.h
+endef
+endif
+
+LAME_POST_CONFIGURE_HOOKS += LAME_BIGENDIAN_ARCH
+
+$(eval $(autotools-package))