summaryrefslogtreecommitdiff
path: root/package/lftp
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 00:27:31 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 12:23:25 +0100
commit91889c19bea220907620c1c40a1869933153a1d0 (patch)
tree9adaac471defe831492d6778080cd3993b8ebf68 /package/lftp
parent797f906ba345fb828cb05aef2404c388a5bfa33b (diff)
package/lftp: add optional support for expat
When expat was compiled before, the proto-http module will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/lftp/4.6.4/proto-http.so | grep NEEDED | sort 0x0000000000000001 (NEEDED) Shared library: [libcrypto.so.1.0.0] 0x0000000000000001 (NEEDED) Shared library: [libc.so.1] 0x0000000000000001 (NEEDED) Shared library: [libdl.so.1] 0x0000000000000001 (NEEDED) Shared library: [libexpat.so.1] [...] The build system offers no option to en-/disable expat support: https://github.com/lavv17/lftp/blob/lftp-4.6-stable/configure.ac#L337 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lftp')
-rw-r--r--package/lftp/lftp.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/lftp/lftp.mk b/package/lftp/lftp.mk
index d2d58fd91..5051f707a 100644
--- a/package/lftp/lftp.mk
+++ b/package/lftp/lftp.mk
@@ -17,6 +17,10 @@ ifneq ($(BR2_STATIC_LIBS),y)
LFTP_CONF_OPTS += --with-modules
endif
+ifeq ($(BR2_PACKAGE_EXPAT)$(BR2_PACKAGE_LFTP_PROTO_HTTP),yy)
+LFTP_DEPENDENCIES += expat
+endif
+
ifeq ($(BR2_PACKAGE_GNUTLS),y)
LFTP_DEPENDENCIES += gnutls
LFTP_CONF_OPTS += --with-gnutls