summaryrefslogtreecommitdiff
path: root/package/libarchive
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-12 23:10:38 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-12 23:10:38 +0200
commit02b93c2136e6cfecdff19785036bcf68aa99f51e (patch)
tree8780336dcb5163ee469610ad57ab523af898ad0f /package/libarchive
parent494b0a5b6b0018bfd05ae5d7c09f57c881ed2b72 (diff)
libarchive: add host variant
This will be needed for the host variant of the fwup package. We enable zlib support since host-fwup needs it. All other features are explicitly disabled. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libarchive')
-rw-r--r--package/libarchive/libarchive.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/libarchive/libarchive.mk b/package/libarchive/libarchive.mk
index 726142b21..e20a737d6 100644
--- a/package/libarchive/libarchive.mk
+++ b/package/libarchive/libarchive.mk
@@ -99,4 +99,21 @@ else
LIBARCHIVE_CONF_OPTS += --without-lzma
endif
+# The only user of host-libarchive needs zlib support
+HOST_LIBARCHIVE_DEPENDENCIES = host-zlib
+HOST_LIBARCHIVE_CONF_OPTS = \
+ --disable-bsdtar \
+ --disable-bsdcpio \
+ --disable-acl \
+ --disable-xattr \
+ --without-bz2lib \
+ --without-expat \
+ --without-libiconv-prefix \
+ --without-xml2 \
+ --without-lzo2 \
+ --without-nettle \
+ --without-openssl \
+ --without-lzma
+
$(eval $(autotools-package))
+$(eval $(host-autotools-package))