summaryrefslogtreecommitdiff
path: root/package/libarchive
diff options
context:
space:
mode:
authorFrank Hunleth <fhunleth@troodon-software.com>2016-07-26 08:58:53 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-27 21:29:07 +0200
commit7ff00b2ad3cd05ba74422e53b1a2d8fb92a18614 (patch)
tree3c3454392c383ba50d3aba3cc1af9017c544fb52 /package/libarchive
parenta8e42c636936c3bc67ad9f7bb8dd77d47aaf23a4 (diff)
libarchive: add selection of bsdcat
libarchive builds three commandline utilities: bsdtar, bsdcpio, and bsdcat. This change adds control over the third utility to the list of configuration options. Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libarchive')
-rw-r--r--package/libarchive/Config.in6
-rw-r--r--package/libarchive/libarchive.mk11
2 files changed, 17 insertions, 0 deletions
diff --git a/package/libarchive/Config.in b/package/libarchive/Config.in
index 81b5936ce..fd429acb6 100644
--- a/package/libarchive/Config.in
+++ b/package/libarchive/Config.in
@@ -24,4 +24,10 @@ config BR2_PACKAGE_LIBARCHIVE_BSDCPIO
The 'bsdcpio' program is a different interface to
essentially the same functionality as 'bsdtar'.
+config BR2_PACKAGE_LIBARCHIVE_BSDCAT
+ bool "bsdcat"
+ help
+ The 'bsdcat' program is a simple replacement tool
+ for zcat, bzcat, xzcat, and such.
+
endif
diff --git a/package/libarchive/libarchive.mk b/package/libarchive/libarchive.mk
index 30a231885..bcf92f907 100644
--- a/package/libarchive/libarchive.mk
+++ b/package/libarchive/libarchive.mk
@@ -30,6 +30,16 @@ else
LIBARCHIVE_CONF_OPTS += --disable-bsdcpio
endif
+ifeq ($(BR2_PACKAGE_LIBARCHIVE_BSDCAT),y)
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBARCHIVE_CONF_OPTS += --enable-bsdcat=static
+else
+LIBARCHIVE_CONF_OPTS += --enable-bsdcat=shared
+endif
+else
+LIBARCHIVE_CONF_OPTS += --disable-bsdcat
+endif
+
ifeq ($(BR2_PACKAGE_ACL),y)
LIBARCHIVE_DEPENDENCIES += acl
else
@@ -105,6 +115,7 @@ HOST_LIBARCHIVE_DEPENDENCIES = host-zlib
HOST_LIBARCHIVE_CONF_OPTS = \
--disable-bsdtar \
--disable-bsdcpio \
+ --disable-bsdcat \
--disable-acl \
--disable-xattr \
--without-bz2lib \