summaryrefslogtreecommitdiff
path: root/package/libarchive
diff options
context:
space:
mode:
authorSergio Prado <sergio.prado@e-labworks.com>2016-07-21 11:10:26 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-23 15:54:31 +0200
commit985543fcfe8327c5b6a137f6043c1bf76f10b456 (patch)
tree39d7c482e26857414951726dd221fb17cfb25dcf /package/libarchive
parent4cf4080087e7d7defa5fc50f42a3c6f94e3979be (diff)
libarchive: fix build error when linking with lzma
Build fails when linking with liblzma compiled without threads support. ./.libs/libarchive.so: undefined reference to `lzma_cputhreads' ./.libs/libarchive.so: undefined reference to `lzma_stream_encoder_mt' So let's enable LZMA only when toolchain has threads support. Fixes: http://autobuild.buildroot.org/results/2cb7f8a056982d0b894d0e2531ef357e74c8b796 http://autobuild.buildroot.org/results/d12954fbd460d396f255158fa127f39ff9d2be8d http://autobuild.buildroot.org/results/abe10c70f38423a212ab27d7d27e22174eaa5aab Many more... Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libarchive')
-rw-r--r--package/libarchive/libarchive.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libarchive/libarchive.mk b/package/libarchive/libarchive.mk
index 6e9c0a1e8..30a231885 100644
--- a/package/libarchive/libarchive.mk
+++ b/package/libarchive/libarchive.mk
@@ -92,7 +92,8 @@ else
LIBARCHIVE_CONF_OPTS += --without-zlib
endif
-ifeq ($(BR2_PACKAGE_XZ),y)
+# libarchive requires LZMA with thread support in the toolchain
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS)$(BR2_PACKAGE_XZ),yy)
LIBARCHIVE_DEPENDENCIES += xz
LIBARCHIVE_CONF_OPTS += --with-lzma
else