summaryrefslogtreecommitdiff
path: root/package/libbdplus
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-07-02 21:25:07 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-03 18:05:58 +0200
commit3cdbedcec47836f947b6f90ae1beed9e77872e20 (patch)
tree33c6aab2300bf09a4f757ac25d0c221fdb01f7fd /package/libbdplus
parentdbe16f2a36b1f0db5e76c4292113c5d5b21f3a32 (diff)
package/libbdplus: new package
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libbdplus')
-rw-r--r--package/libbdplus/Config.in17
-rw-r--r--package/libbdplus/libbdplus.hash2
-rw-r--r--package/libbdplus/libbdplus.mk31
3 files changed, 50 insertions, 0 deletions
diff --git a/package/libbdplus/Config.in b/package/libbdplus/Config.in
new file mode 100644
index 000000000..19170a61a
--- /dev/null
+++ b/package/libbdplus/Config.in
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_LIBBDPLUS
+ bool "libbdplus"
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on !BR2_STATIC_LIBS
+ help
+ libbdplus is a research project to implement the BD+ System
+ Specifications.
+ This research project provides, through an open-source
+ library, a way to understand how the BD+ works.
+ NB: this project doesn't offer any key, configuration file or
+ certificate that could be used to decode encrypted copyrighted
+ material.
+
+ http://www.videolan.org/developers/libbdplus.html
+
+comment "libbdplus needs a toolchain w/ threads, dynamic library"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
diff --git a/package/libbdplus/libbdplus.hash b/package/libbdplus/libbdplus.hash
new file mode 100644
index 000000000..552cd71c8
--- /dev/null
+++ b/package/libbdplus/libbdplus.hash
@@ -0,0 +1,2 @@
+# From http://download.videolan.org/pub/videolan/libbdplus/0.1.2/libbdplus-0.1.2.tar.bz2.sha512
+sha512 e00e7bc9f52b9275646593b753ba646b052255be94a7241965f4dbe4734f8f6a072973ed4b9997957f939236b0633897c295749f79e232188430795be5b5087b libbdplus-0.1.2.tar.bz2
diff --git a/package/libbdplus/libbdplus.mk b/package/libbdplus/libbdplus.mk
new file mode 100644
index 000000000..45913edda
--- /dev/null
+++ b/package/libbdplus/libbdplus.mk
@@ -0,0 +1,31 @@
+################################################################################
+#
+# libbdplus
+#
+################################################################################
+
+LIBBDPLUS_VERSION = 0.1.2
+LIBBDPLUS_SITE = http://download.videolan.org/pub/videolan/libbdplus/$(LIBBDPLUS_VERSION)
+LIBBDPLUS_SOURCE = libbdplus-$(LIBBDPLUS_VERSION).tar.bz2
+LIBBDPLUS_LICENSE = LGPLv2.1+
+LIBBDPLUS_LICENSE_FILES = COPYING
+LIBBDPLUS_INSTALL_STAGING = YES
+LIBBDPLUS_DEPENDENCIES = libgcrypt
+LIBBDPLUS_CONF_OPTS = \
+ --disable-werror \
+ --disable-extra-warnings \
+ --disable-optimizations \
+ --disable-examples \
+ --disable-debug \
+ --with-gnu-ld \
+ --with-libgcrypt-prefix=$(STAGING_DIR)/usr \
+ --with-gpg-error-prefix=$(STAGING_DIR)/usr
+
+ifeq ($(BR2_PACKAGE_LIBAACS),y)
+LIBBDPLUS_DEPENDENCIES += libaacs
+LIBBDPLUS_CONF_OPTS += --with-libaacs
+else
+LIBBDPLUS_CONF_OPTS += --without-libaacs
+endif
+
+$(eval $(autotools-package))