summaryrefslogtreecommitdiff
path: root/package/libcec
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-06-05 01:04:10 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-08 15:09:58 +0200
commita19bb4b873a9592b3cc16ad992e473f7d56a0b35 (patch)
tree09d5ce6a8a0a8c10c6f7da80f26522de66a63c8a /package/libcec
parenta0d0abc16024153f0e1e18166e71a58b4eae08cb (diff)
package/libcec: fix missing libraries from rpi-userland
When rpi-userland libraries are built as shared-objects, not all needed libraries are passed in the LD_FLAGS, leading to failure at linkage. To avoid this issue, set the LIBS variable content in accordance with INCLUDES variable value. This is needed because libcec does not use pkg-config to look for the ldflags needed for -lbcm_host, even though bcm_host provides a .pc file (even a correct one!) Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Samuel Martin <s.martin49@gmail.com> Tested-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libcec')
-rw-r--r--package/libcec/libcec.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/libcec/libcec.mk b/package/libcec/libcec.mk
index 0aabb0611..ad919fc06 100644
--- a/package/libcec/libcec.mk
+++ b/package/libcec/libcec.mk
@@ -26,6 +26,7 @@ ifeq ($(BR2_PACKAGE_RPI_USERLAND),y)
LIBCEC_CONF_OPT = --enable-rpi \
--with-rpi-include-path=$(STAGING_DIR)/usr/include
LIBCEC_DEPENDENCIES += rpi-userland
+LIBCEC_CONF_ENV += LIBS="-lvcos -lvchostif"
else
LIBCEC_CONF_OPT = --disable-rpi
endif