summaryrefslogtreecommitdiff
path: root/package/libcgroup
diff options
context:
space:
mode:
authorClayton Shotwell <clshotwe@rockwellcollins.com>2013-10-02 07:46:04 -0500
committerPeter Korsgaard <peter@korsgaard.com>2013-10-02 21:59:38 +0200
commitff7191c12e88b044848f6655f7015335235bdc7a (patch)
treef44b731a3a01886e8cfa8de77e43b0c036b834a6 /package/libcgroup
parent574ab8ce9a08d751f8f1d615ec550e6f162f0077 (diff)
libcgroup: new package
Signed-off-by: Clayton Shotwell <clshotwe@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libcgroup')
-rw-r--r--package/libcgroup/Config.in13
-rw-r--r--package/libcgroup/libcgroup.mk34
2 files changed, 47 insertions, 0 deletions
diff --git a/package/libcgroup/Config.in b/package/libcgroup/Config.in
new file mode 100644
index 000000000..0f5c09760
--- /dev/null
+++ b/package/libcgroup/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LIBCGROUP
+ bool "libcgroup"
+ depends on BR2_INSTALL_LIBSTDCPP
+ # libcgroup uses <fts.h> which is not included by default in uClibc
+ depends on BR2_TOOLCHAIN_USES_GLIBC
+ help
+ libcgroup is a library that abstracts the control
+ group file system in Linux.
+
+ http://libcg.sourceforge.net/
+
+comment "libcgroup requires a glibc toolchain with C++ support"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_USES_GLIBC
diff --git a/package/libcgroup/libcgroup.mk b/package/libcgroup/libcgroup.mk
new file mode 100644
index 000000000..c2392e0b8
--- /dev/null
+++ b/package/libcgroup/libcgroup.mk
@@ -0,0 +1,34 @@
+################################################################################
+#
+# libcgroup
+#
+################################################################################
+
+LIBCGROUP_VERSION = 0.38
+LIBCGROUP_SOURCE = libcgroup-$(LIBCGROUP_VERSION).tar.bz2
+LIBCGROUP_SITE = http://downloads.sourceforge.net/project/libcg/libcgroup/v.038
+LIBCGROUP_LICENSE = LGPLv2.1
+LIBCGROUP_LICENSE_FILES = COPYING
+
+LIBCGROUP_INSTALL_STAGING = YES
+
+# Undefining _FILE_OFFSET_BITS here because of a "bug" with glibc fts.h
+# large file support. See https://bugzilla.redhat.com/show_bug.cgi?id=574992
+# for more information.
+LIBCGROUP_CONF_ENV = \
+ CXXFLAGS+="-U_FILE_OFFSET_BITS" \
+ CFLAGS+="-U_FILE_OFFSET_BITS"
+
+LIBCGROUP_CONF_OPT = \
+ --disable-tools \
+ --disable-daemon \
+ --disable-initscript-install
+
+ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
+ LIBCGROUP_DEPENDENCIES += linux-pam
+ LIBCGROUP_CONF_OPT += --enable-pam
+else
+ LIBCGROUP_CONF_OPT += --disable-pam
+endif
+
+$(eval $(autotools-package))