summaryrefslogtreecommitdiff
path: root/package/libcurl
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2015-04-23 17:01:36 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-23 22:59:05 +0200
commit63b1fa81ec0bee74d459cfec487045db48408e4f (patch)
tree4916b982f8a0c1fa5207f9bd0d81016c41fc65fd /package/libcurl
parentd78dd4b672268f68c71d71c550f3bc6c7ea73a08 (diff)
libcurl: disable curldebug
curldebug is a more advanced form of debugging for curl which audits source code with the checksource.pl tool, and treats warnings as errors. Normally users won't want/need this so disable it since it leads to failed builds when debug info is enabled (which is what people normally want). When buildroot does --enable-debug curl inherently enables curldebug too. Solves bug #8041. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libcurl')
-rw-r--r--package/libcurl/libcurl.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
index acb2b42b9..33903997c 100644
--- a/package/libcurl/libcurl.mk
+++ b/package/libcurl/libcurl.mk
@@ -20,7 +20,7 @@ LIBCURL_INSTALL_STAGING = YES
# probably almost never used. See
# http://curl.haxx.se/docs/manpage.html#--ntlm.
LIBCURL_CONF_OPTS = --disable-verbose --disable-manual --disable-ntlm-wb \
- --enable-hidden-symbols --with-random=/dev/urandom
+ --enable-hidden-symbols --with-random=/dev/urandom --disable-curldebug
LIBCURL_CONFIG_SCRIPTS = curl-config
ifeq ($(BR2_PACKAGE_OPENSSL),y)