summaryrefslogtreecommitdiff
path: root/package/libeXosip2
diff options
context:
space:
mode:
authorMischa Jonker <mischa.jonker@synopsys.com>2013-07-15 14:39:22 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-15 22:53:42 +0200
commit821a6d6338451d76d6856ab9c0bfe1a709543b4b (patch)
tree1aea3d091cc7763abfba7ac907dc0629e72e92f8 /package/libeXosip2
parentfd9c3e2bdaaea7bc54b2ea2c979a2ae061ed5149 (diff)
libosip2: arc: Undefine __arc__ when building for ARC processors
libosip2 appears to have support for the "ARC standard" (Advanced RISC Computing), which is unrelated to Synopsys DesignWare ARC processors. The check for this involves verifying the existence of the "__arc__" macro. Unfortunately, this macro is also present as a predefined built-in for the ARC processors, resulting into build failures. [Peter: add short comment in .mk files as well] Signed-off-by: Mischa Jonker <mjonker@synopsys.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libeXosip2')
-rw-r--r--package/libeXosip2/libeXosip2.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/libeXosip2/libeXosip2.mk b/package/libeXosip2/libeXosip2.mk
index 4be2f05a9..6abdaab8a 100644
--- a/package/libeXosip2/libeXosip2.mk
+++ b/package/libeXosip2/libeXosip2.mk
@@ -12,6 +12,11 @@ LIBEXOSIP2_LICENSE_FILES = COPYING
LIBEXOSIP2_DEPENDENCIES = host-pkgconf libosip2
+ifeq ($(BR2_arc),y)
+# toolchain __arc__ define conflicts with libeXosip2 source
+LIBEXOSIP2_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -U__arc__"
+endif
+
ifeq ($(BR2_PACKAGE_OPENSSL),y)
LIBEXOSIP2_DEPENDENCIES += openssl
LIBEXOSIP2_CONF_OPT += --enable-openssl