summaryrefslogtreecommitdiff
path: root/package/libebur128
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-07-24 17:53:17 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-24 21:53:20 +0200
commita32d29cd84789d7406022c7bb9861e5bda530013 (patch)
tree2fbfe5f47d2f56be65b715a37377f4798abdc10a /package/libebur128
parent560334bb2a46a77081a3944d092df7732dfca432 (diff)
package/libebur128: new package
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libebur128')
-rw-r--r--package/libebur128/Config.in14
-rw-r--r--package/libebur128/libebur128.mk14
2 files changed, 28 insertions, 0 deletions
diff --git a/package/libebur128/Config.in b/package/libebur128/Config.in
new file mode 100644
index 000000000..1a6a74363
--- /dev/null
+++ b/package/libebur128/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LIBEBUR128
+ bool "libebur128"
+ # build system has no support to disable shared linking
+ # leading to a build error with a static-only toolchain
+ depends on !BR2_STATIC_LIBS
+ select BR2_PACKAGE_SPEEX
+ help
+ libebur128 is a library that implements the EBU R 128 standard
+ for loudness normalization.
+
+ https://github.com/jiixyj/libebur128
+
+comment "libebur128 needs a toolchain w/ dynamic library"
+ depends on BR2_STATIC_LIBS
diff --git a/package/libebur128/libebur128.mk b/package/libebur128/libebur128.mk
new file mode 100644
index 000000000..f5ada311f
--- /dev/null
+++ b/package/libebur128/libebur128.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# libebur128
+#
+################################################################################
+
+LIBEBUR128_VERSION = v1.1.0
+LIBEBUR128_SITE = $(call github,jiixyj,libebur128,$(LIBEBUR128_VERSION))
+LIBEBUR128_LICENSE = MIT
+LIBEBUR128_LICENSE_FILES = COPYING
+LIBEBUR128_INSTALL_STAGING = YES
+LIBEBUR128_DEPENDENCIES = speex
+
+$(eval $(cmake-package))