summaryrefslogtreecommitdiff
path: root/package/libee
diff options
context:
space:
mode:
authorClayton Shotwell <clshotwe@rockwellcollins.com>2014-03-12 12:51:07 -0500
committerPeter Korsgaard <peter@korsgaard.com>2014-03-15 23:20:39 +0100
commitbf25237ff3569596a674d2bc3f6c6028fb978478 (patch)
tree748f4e26b1cf7a81063dfd4c99d099894d95bea3 /package/libee
parent3ea048fd1f9825be4023db40e152de8948ee2498 (diff)
libee: new package
[Peter: needs host-pkgconf to find libestr] Signed-off-by: Clayton Shotwell <clshotwe@rockwellcollins.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libee')
-rw-r--r--package/libee/Config.in19
-rw-r--r--package/libee/libee.mk16
2 files changed, 35 insertions, 0 deletions
diff --git a/package/libee/Config.in b/package/libee/Config.in
new file mode 100644
index 000000000..9a3411ef2
--- /dev/null
+++ b/package/libee/Config.in
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_LIBEE
+ bool "libee"
+ select BR2_PACKAGE_LIBESTR
+ help
+ An Event Expression Library inspired by CEE.
+
+ CEE is an upcoming standard used to describe network
+ events in a number of normalized formats. It's goal is
+ to unify they currently many different representations
+ that exist in the industry.
+
+ The core idea of libee is to provide a small but hopefully
+ convenient API layer above the CEE standard. However, CEE
+ is not finished. At the time of this writing, CEE is under
+ heavy development and even some of its core data structures
+ (like the data dictionary and taxonmy) have not been fully
+ specified.
+
+ http://www.libee.org
diff --git a/package/libee/libee.mk b/package/libee/libee.mk
new file mode 100644
index 000000000..f6d36b604
--- /dev/null
+++ b/package/libee/libee.mk
@@ -0,0 +1,16 @@
+################################################################################
+#
+# libee
+#
+################################################################################
+
+LIBEE_VERSION = 0.4.1
+LIBEE_SITE = http://www.libee.org/download/files/download/
+LIBEE_LICENSE = LGPLv2.1+
+LIBEE_LICENSE_FILES = COPYING
+LIBEE_DEPENDENCIES = libestr host-pkgconf
+LIBEE_INSTALL_STAGING = YES
+
+LIBEE_MAKE = $(MAKE1)
+
+$(eval $(autotools-package))