summaryrefslogtreecommitdiff
path: root/package/libev
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-08-26 08:36:17 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-08-26 23:49:18 +0200
commit5de840cc6a9370c0765da4ad55cd116c96ef741c (patch)
tree36f6258fbcba02b9c73b8a8fbe8cf2fd0f922da3 /package/libev
parentfdff7150896163e2962eb5172c7606afe2ca1fd7 (diff)
libev: don't install event.h
It's a 'compatibility layer' with libevent which we: 1) Don't need 2) Possibly outdated with respect to libevent2 3) Causes build failures Fixes: http://autobuild.buildroot.net/results/451/4510fe02ef3497803ed27bf339dca07b3b073c10/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libev')
-rw-r--r--package/libev/libev.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/libev/libev.mk b/package/libev/libev.mk
index a6ff3a92c..dc428583f 100644
--- a/package/libev/libev.mk
+++ b/package/libev/libev.mk
@@ -10,4 +10,11 @@ LIBEV_INSTALL_STAGING = YES
LIBEV_LICENSE = BSD-2c or GPLv2+
LIBEV_LICENSE_FILES = LICENSE
+# The 'compatibility' event.h header conflicts with libevent
+# It's completely unnecessary for BR packages so remove it
+define LIBEV_DISABLE_EVENT_H_INSTALL
+ $(SED) 's/ event.h//' $(@D)/Makefile.in
+endef
+LIBEV_POST_PATCH_HOOKS += LIBEV_DISABLE_EVENT_H_INSTALL
+
$(eval $(autotools-package))