summaryrefslogtreecommitdiff
path: root/package/libffi
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-03 22:17:49 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-03 22:22:01 +0100
commit2b73538920107b6c020ce5c4c8d9f7f672549bb1 (patch)
treefdf3c773b0ad6960dff8548a3f102ba2a3425b6a /package/libffi
parentffde67a0de3c7849758c450019e6a8b23c98ea68 (diff)
libffi: fix staging headers cleanup
The LIBFFI_MOVE_STAGING_HEADERS function is responsible for moving around libffi headers to a standard location. Once this is done, it removes the no longer used directory, but does so in $(TARGET_DIR) and not $(STAGING_DIR). This directory is already cleaned up in $(TARGET_DIR) in the LIBFFI_REMOVE_TARGET_HEADERS post-install target hook. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libffi')
-rw-r--r--package/libffi/libffi.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libffi/libffi.mk b/package/libffi/libffi.mk
index 8f0f72d93..3373c1712 100644
--- a/package/libffi/libffi.mk
+++ b/package/libffi/libffi.mk
@@ -17,7 +17,7 @@ define LIBFFI_MOVE_STAGING_HEADERS
mv $(STAGING_DIR)/usr/lib/libffi-$(LIBFFI_VERSION)/include/*.h $(STAGING_DIR)/usr/include/
$(SED) '/^includedir.*/d' -e '/^Cflags:.*/d' \
$(STAGING_DIR)/usr/lib/pkgconfig/libffi.pc
- rm -rf $(TARGET_DIR)/usr/lib/libffi-*
+ rm -rf $(STAGING_DIR)/usr/lib/libffi-*
endef
LIBFFI_POST_INSTALL_STAGING_HOOKS += LIBFFI_MOVE_STAGING_HEADERS