summaryrefslogtreecommitdiff
path: root/package/libffi
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-28 23:52:20 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-07-01 14:56:51 +0200
commite5573e723695a830c05ae7a2649d811abc6b5061 (patch)
tree27bb95615d8fa67e77674c8d82a3118ed158ff48 /package/libffi
parent5f1fa660eab275dc25cf5c9de4befbcbf01a0baa (diff)
libffi: remove some header files installed in /usr/lib in the target
For some reason, libffi installs some header files in /usr/lib/libffi-<version>/include, which is a non-standard location and therefore they do not get removed automatically by the target-finalize logic. This commit adds a post-install hook in libffi.mk to get rid of these unneeded headers on the target. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libffi')
-rw-r--r--package/libffi/libffi.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/libffi/libffi.mk b/package/libffi/libffi.mk
index dc7132d35..1377b8f4b 100644
--- a/package/libffi/libffi.mk
+++ b/package/libffi/libffi.mk
@@ -22,6 +22,12 @@ endef
LIBFFI_POST_INSTALL_STAGING_HOOKS += LIBFFI_MOVE_STAGING_HEADERS
+# Remove headers that are not at the usual location from the target
+define LIBFFI_REMOVE_TARGET_HEADERS
+ $(RM) -rf $(TARGET_DIR)/usr/lib/libffi-$(LIBFFI_VERSION)
+endef
+
+LIBFFI_POST_INSTALL_TARGET_HOOKS += LIBFFI_REMOVE_TARGET_HEADERS
$(eval $(autotools-package))
$(eval $(host-autotools-package))