summaryrefslogtreecommitdiff
path: root/package/libfm
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 11:51:25 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 14:45:36 +0100
commit018843ce1bfe1c83d12a3e12f9b9b4c986ec9e7d (patch)
tree2a81f659398589bb1b047fd3cd5d49de9bdbb6e0 /package/libfm
parent6fa25a8fb7ee6b612ba8240d02e05a5ef3a9c6e0 (diff)
package/libfm: add optional support for libexif
When libexif was compiled before, libfm will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/libfm.so.4.0.3 | grep NEEDED | sort 0x0000000000000001 (NEEDED) Shared library: [libc.so.1] 0x0000000000000001 (NEEDED) Shared library: [libdl.so.1] 0x0000000000000001 (NEEDED) Shared library: [libexif.so.12] [...] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libfm')
-rw-r--r--package/libfm/libfm.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/libfm/libfm.mk b/package/libfm/libfm.mk
index f0888b7e2..e8410d028 100644
--- a/package/libfm/libfm.mk
+++ b/package/libfm/libfm.mk
@@ -12,4 +12,11 @@ LIBFM_LICENSE = GPLv2+, LGPLv2.1+
LIBFM_LICENSE_FILES = COPYING src/extra/fm-xml-file.c
LIBFM_INSTALL_STAGING = YES
+ifeq ($(BR2_PACKAGE_LIBEXIF),y)
+LIBFM_CONF_OPTS += --enable-exif
+LIBFM_DEPENDENCIES += libexif
+else
+LIBFM_CONF_OPTS += --disable-exif
+endif
+
$(eval $(autotools-package))