summaryrefslogtreecommitdiff
path: root/package/libfm
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2014-11-21 15:33:09 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-13 02:16:09 +0200
commit1b43e91af36a137940b0ebff62c2d2f54c14103e (patch)
tree0eddf36b4d20e5d0e93d5e33014f79cbbb54375e /package/libfm
parent91489ddc48c439004e718667f117fce391658577 (diff)
libfm: new package
[Thomas: - switch from 'select BR2_PACKAGE_XORG7' to 'depends on BR2_PACKAGE_XORG7' as suggested by Yann E. Morin. - add LGPLv2.1+ in the list of licenses as well as a corresponding license file, as suggested by Yann E. Morin.] Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libfm')
-rw-r--r--package/libfm/Config.in28
-rw-r--r--package/libfm/libfm.hash2
-rw-r--r--package/libfm/libfm.mk15
3 files changed, 45 insertions, 0 deletions
diff --git a/package/libfm/Config.in b/package/libfm/Config.in
new file mode 100644
index 000000000..c6cfcf6d4
--- /dev/null
+++ b/package/libfm/Config.in
@@ -0,0 +1,28 @@
+config BR2_PACKAGE_LIBFM
+ bool "libfm"
+ select BR2_PACKAGE_MENU_CACHE
+ select BR2_PACKAGE_LIBGLIB2
+ select BR2_PACKAGE_LIBGTK2
+ select BR2_PACKAGE_CAIRO
+ depends on BR2_PACKAGE_XORG7
+ depends on BR2_USE_WCHAR # libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+ depends on BR2_USE_MMU # libglib2
+ depends on BR2_INSTALL_LIBSTDCPP # libgtk2
+ depends on BR2_ARCH_HAS_ATOMICS # libgtk2
+ help
+ A glib/gio-based library providing some file management
+ utilities and related-widgets missing in gtk+/glib. This is
+ the core of PCManFM. The library is desktop independent
+ (not LXDE specific) and has clean API. It can be used to
+ develop other applications requiring file management
+ functionality. For example, you can create your own file
+ manager with facilities provided by libfm.
+
+ http://wiki.lxde.org/en/Libfm
+
+comment "libfm needs X.org and a toolchain w/ wchar, threads, C++"
+ depends on BR2_USE_MMU
+ depends on BR2_ARCH_HAS_ATOMICS
+ depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP || \
+ !BR2_TOOLCHAIN_HAS_THREADS || !BR2_PACKAGE_XORG7
diff --git a/package/libfm/libfm.hash b/package/libfm/libfm.hash
new file mode 100644
index 000000000..5311deccf
--- /dev/null
+++ b/package/libfm/libfm.hash
@@ -0,0 +1,2 @@
+# From http://blog.lxde.org/?p=1280
+sha1 c3f2f34086761d89d6aba549883610084ba00750 libfm-1.2.3.tar.xz
diff --git a/package/libfm/libfm.mk b/package/libfm/libfm.mk
new file mode 100644
index 000000000..f0888b7e2
--- /dev/null
+++ b/package/libfm/libfm.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libfm
+#
+################################################################################
+
+LIBFM_VERSION = 1.2.3
+LIBFM_SOURCE = libfm-$(LIBFM_VERSION).tar.xz
+LIBFM_SITE = http://sourceforge.net/projects/pcmanfm/files
+LIBFM_DEPENDENCIES = menu-cache libgtk2 libglib2 cairo
+LIBFM_LICENSE = GPLv2+, LGPLv2.1+
+LIBFM_LICENSE_FILES = COPYING src/extra/fm-xml-file.c
+LIBFM_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))