summaryrefslogtreecommitdiff
path: root/package/libgpgme
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2016-05-24 15:30:17 +0300
committerPeter Korsgaard <peter@korsgaard.com>2016-05-24 21:50:36 +0200
commit9d217aa4dd987128ba874d3c6ee2255ffed10305 (patch)
tree578efd9f1aee9e927339d9c2f93f202639177cc8 /package/libgpgme
parent45eaede51b6817abc53e71d9e73c4c17ee29039e (diff)
libgpgme: fix musl build with argp-standalone
The libgpgme configure script does not detect the error_t type under musl, because musl does not define error_t in errno.h. As a result config.h adds a local definition of error_t. When argp-standalone is present this local definition collides with the error_t typedef in argp.h. Assume we always have error_t when argp-standalone is present. Fixes: http://autobuild.buildroot.net/results/656/6566a1c77983404d90920997bfd15bd98c7ddde7/ http://autobuild.buildroot.net/results/a7b/a7b92ad68ff6e13d20ff44e955dc5748b2efd6a4/ http://autobuild.buildroot.net/results/0db/0db1b2aa0969d6cbae57b1400b7b766a5988abf9/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libgpgme')
-rw-r--r--package/libgpgme/libgpgme.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/libgpgme/libgpgme.mk b/package/libgpgme/libgpgme.mk
index 186809985..574ddd6be 100644
--- a/package/libgpgme/libgpgme.mk
+++ b/package/libgpgme/libgpgme.mk
@@ -23,7 +23,9 @@ LIBGPGME_CONF_OPTS = --with-gpg=/usr/bin/gpg \
# Handle argp-standalone or it errors out during build
ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
-LIBGPGME_CONF_ENV += LIBS="-largp"
+# musl libc does not define error_t in errno.h, but argp.h does.
+# Assume we have error_t to avoid collision with the argp.h error_t.
+LIBGPGME_CONF_ENV += LIBS="-largp" ac_cv_type_error_t=yes
LIBGPGME_DEPENDENCIES += argp-standalone
endif