summaryrefslogtreecommitdiff
path: root/package/libhdhomerun
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-01-23 10:44:56 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-25 23:16:08 +0100
commitca7c9d459752b799eda13e86ba9241c06b056635 (patch)
treec1b72de05060f0356e61e8d3d12229f045de26c1 /package/libhdhomerun
parent2158bd6ae1f0627bdd645bca54c5476c522f33a7 (diff)
package/libhdhomerun: fix header install path
Header files are expected to be installed in usr/include/libhdhomerun/ https://packages.debian.org/sid/i386/libhdhomerun-dev/filelist https://github.com/tvheadend/tvheadend/blob/master/src/input/mpegts/tvhdhomerun/tvhdhomerun_private.h#L27 This patch will fix a build error with hdhomerun support enabled in tvheadend. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libhdhomerun')
-rw-r--r--package/libhdhomerun/libhdhomerun.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libhdhomerun/libhdhomerun.mk b/package/libhdhomerun/libhdhomerun.mk
index e3e5f064b..16e34c238 100644
--- a/package/libhdhomerun/libhdhomerun.mk
+++ b/package/libhdhomerun/libhdhomerun.mk
@@ -19,8 +19,9 @@ endef
define LIBHDHOMERUN_INSTALL_STAGING_CMDS
$(INSTALL) -D -m 0755 $(@D)/libhdhomerun.so \
$(STAGING_DIR)/usr/lib/libhdhomerun.so
+ mkdir -p $(STAGING_DIR)/usr/include/libhdhomerun/
$(INSTALL) -m 0644 $(@D)/*.h \
- $(STAGING_DIR)/usr/include/
+ $(STAGING_DIR)/usr/include/libhdhomerun/
endef
define LIBHDHOMERUN_INSTALL_TARGET_CMDS