summaryrefslogtreecommitdiff
path: root/package/libinput
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-11-14 00:26:35 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-11-14 23:07:37 +0100
commit5101ea58d52fe4edd9ac74d6f144ade1e374bf50 (patch)
treecf8b998ee274df6d508cb39f967f26ecdd0e5712 /package/libinput
parenta458f926bb6afce2791ffb5e76595c7e4834126d (diff)
package/libinput: bump version to 1.1.0
Also rebased 0001-rename-log_msg-to-libinput_log_msg.patch. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libinput')
-rw-r--r--package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch24
-rw-r--r--package/libinput/libinput.hash4
-rw-r--r--package/libinput/libinput.mk2
3 files changed, 22 insertions, 8 deletions
diff --git a/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch b/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch
index 433b29ef0..e36862a12 100644
--- a/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch
+++ b/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch
@@ -22,9 +22,9 @@ diff --git a/src/libinput-private.h b/src/libinput-private.h
index b36dc95..98f91b3 100644
--- a/src/libinput-private.h
+++ b/src/libinput-private.h
-@@ -179,15 +179,15 @@ struct libinput_event_listener {
- typedef void (*libinput_source_dispatch_t)(void *data);
+@@ -259,12 +259,12 @@
+ typedef void (*libinput_source_dispatch_t)(void *data);
-#define log_debug(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_DEBUG, __VA_ARGS__)
-#define log_info(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_INFO, __VA_ARGS__)
@@ -39,17 +39,22 @@ index b36dc95..98f91b3 100644
+#define log_bug_libinput(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "libinput bug: " __VA_ARGS__)
+#define log_bug_client(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "client bug: " __VA_ARGS__)
+ #define log_debug_ratelimit(li_, r_, ...) log_msg_ratelimit((li_), (r_), LIBINPUT_LOG_PRIORITY_DEBUG, __VA_ARGS__)
+ #define log_info_ratelimit(li_, r_, ...) log_msg_ratelimit((li_), (r_), LIBINPUT_LOG_PRIORITY_INFO, __VA_ARGS__)
+@@ -281,7 +281,7 @@
+ LIBINPUT_ATTRIBUTE_PRINTF(4, 5);
+
void
-log_msg(struct libinput *libinput,
+libinput_log_msg(struct libinput *libinput,
enum libinput_log_priority priority,
- const char *format, ...);
-
+ const char *format, ...)
+ LIBINPUT_ATTRIBUTE_PRINTF(3, 4);
diff --git a/src/libinput.c b/src/libinput.c
index 279cce0..5748e5e 100644
--- a/src/libinput.c
+++ b/src/libinput.c
-@@ -107,7 +107,7 @@ log_msg_va(struct libinput *libinput,
+@@ -155,7 +155,7 @@
}
void
@@ -58,6 +63,15 @@ index 279cce0..5748e5e 100644
enum libinput_log_priority priority,
const char *format, ...)
{
+@@ -184,7 +184,7 @@
+ va_end(args);
+
+ if (state == RATELIMIT_THRESHOLD)
+- log_msg(libinput,
++ libinput_log_msg(libinput,
+ priority,
+ "WARNING: log rate limit exceeded (%d msgs per %dms). Discarding future messages.\n",
+ ratelimit->burst,
--
2.1.2
diff --git a/package/libinput/libinput.hash b/package/libinput/libinput.hash
index 299a28f98..18bd4a745 100644
--- a/package/libinput/libinput.hash
+++ b/package/libinput/libinput.hash
@@ -1,2 +1,2 @@
-# From http://lists.freedesktop.org/archives/wayland-devel/2015-July/023184.html
-sha256 69a97da47ef8fa9debadaa8ee11005b9b5183bd2b87c5aa7827b7c388a5acc5d libinput-0.19.0.tar.xz
+# From http://lists.freedesktop.org/archives/wayland-devel/2015-October/025065.html
+sha256 673186ea2a0d2b695afaa9758834f9217b175774d9ae222e1b43ff63c663f582 libinput-1.1.0.tar.xz
diff --git a/package/libinput/libinput.mk b/package/libinput/libinput.mk
index 175e04f50..8b51b2b33 100644
--- a/package/libinput/libinput.mk
+++ b/package/libinput/libinput.mk
@@ -4,7 +4,7 @@
#
################################################################################
-LIBINPUT_VERSION = 0.19.0
+LIBINPUT_VERSION = 1.1.0
LIBINPUT_SOURCE = libinput-$(LIBINPUT_VERSION).tar.xz
LIBINPUT_SITE = http://www.freedesktop.org/software/libinput
LIBINPUT_LICENSE = MIT