summaryrefslogtreecommitdiff
path: root/package/libinput
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2016-06-01 17:55:16 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-06-01 17:55:16 +0200
commit577021e81b0bf894d26d8127822410267b2bb411 (patch)
tree8b93cd2342bc73294c9a7695cf8d558da7f16503 /package/libinput
parent206ce569269a4b0b7d3ae60f9162d40b290726d8 (diff)
parent5386c61796feb30a02ec287ad769a6754aa525dd (diff)
Merge branch 'next'
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libinput')
-rw-r--r--package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch77
-rw-r--r--package/libinput/libinput.hash4
-rw-r--r--package/libinput/libinput.mk2
3 files changed, 3 insertions, 80 deletions
diff --git a/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch b/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch
deleted file mode 100644
index e36862a12..000000000
--- a/package/libinput/0001-rename-log_msg-to-libinput_log_msg.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From bf4a4a4e2b0479322fe16c9e1f15f146daa893ee Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@openwide.fr>
-Date: Thu, 21 Aug 2014 18:18:16 +0200
-Subject: [PATCH] rename log_msg to libinput_log_msg
-
-This fixes a conflict between libevdev and libinput on the definition
-of the log_msg() symbol.
-
-http://autobuild.buildroot.net/results/c13/c133b7c706ee31302125df8ca94f4d0f0152c6c6/build-end.log
-
-Signed-off-by: Romain Naour <romain.naour@openwide.fr>
-[yann.morin.1998@free.fr: rebase on-top of 0.6.0]
-Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
-[ps.report@gmx.net: rebase on top of 0.7.0]
-Signed-off-by: Peter Seiderer <ps.report@gmx.net>
----
- src/libinput-private.h | 14 +++++++-------
- src/libinput.c | 2 +-
- 2 files changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/src/libinput-private.h b/src/libinput-private.h
-index b36dc95..98f91b3 100644
---- a/src/libinput-private.h
-+++ b/src/libinput-private.h
-@@ -259,12 +259,12 @@
-
- typedef void (*libinput_source_dispatch_t)(void *data);
-
--#define log_debug(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_DEBUG, __VA_ARGS__)
--#define log_info(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_INFO, __VA_ARGS__)
--#define log_error(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, __VA_ARGS__)
--#define log_bug_kernel(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "kernel bug: " __VA_ARGS__)
--#define log_bug_libinput(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "libinput bug: " __VA_ARGS__)
--#define log_bug_client(li_, ...) log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "client bug: " __VA_ARGS__)
-+#define log_debug(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_DEBUG, __VA_ARGS__)
-+#define log_info(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_INFO, __VA_ARGS__)
-+#define log_error(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, __VA_ARGS__)
-+#define log_bug_kernel(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "kernel bug: " __VA_ARGS__)
-+#define log_bug_libinput(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "libinput bug: " __VA_ARGS__)
-+#define log_bug_client(li_, ...) libinput_log_msg((li_), LIBINPUT_LOG_PRIORITY_ERROR, "client bug: " __VA_ARGS__)
-
- #define log_debug_ratelimit(li_, r_, ...) log_msg_ratelimit((li_), (r_), LIBINPUT_LOG_PRIORITY_DEBUG, __VA_ARGS__)
- #define log_info_ratelimit(li_, r_, ...) log_msg_ratelimit((li_), (r_), LIBINPUT_LOG_PRIORITY_INFO, __VA_ARGS__)
-@@ -281,7 +281,7 @@
- LIBINPUT_ATTRIBUTE_PRINTF(4, 5);
-
- void
--log_msg(struct libinput *libinput,
-+libinput_log_msg(struct libinput *libinput,
- enum libinput_log_priority priority,
- const char *format, ...)
- LIBINPUT_ATTRIBUTE_PRINTF(3, 4);
-diff --git a/src/libinput.c b/src/libinput.c
-index 279cce0..5748e5e 100644
---- a/src/libinput.c
-+++ b/src/libinput.c
-@@ -155,7 +155,7 @@
- }
-
- void
--log_msg(struct libinput *libinput,
-+libinput_log_msg(struct libinput *libinput,
- enum libinput_log_priority priority,
- const char *format, ...)
- {
-@@ -184,7 +184,7 @@
- va_end(args);
-
- if (state == RATELIMIT_THRESHOLD)
-- log_msg(libinput,
-+ libinput_log_msg(libinput,
- priority,
- "WARNING: log rate limit exceeded (%d msgs per %dms). Discarding future messages.\n",
- ratelimit->burst,
---
-2.1.2
-
diff --git a/package/libinput/libinput.hash b/package/libinput/libinput.hash
index 43fcf5dde..faf95c39f 100644
--- a/package/libinput/libinput.hash
+++ b/package/libinput/libinput.hash
@@ -1,2 +1,2 @@
-# From https://lists.freedesktop.org/archives/wayland-devel/2016-April/028215.html
-sha256 aee3650ad2a864ab9a10e7e63df543cc2b475f6bf3974751037a2df325dabbb1 libinput-1.2.4.tar.xz
+# From https://lists.freedesktop.org/archives/wayland-devel/2016-May/029126.html
+sha256 cdff653d93395c718f367af61fee866914bc45de75ac94abe7dc1b720462aca9 libinput-1.3.1.tar.xz
diff --git a/package/libinput/libinput.mk b/package/libinput/libinput.mk
index bd8fe2cbc..2ff0de368 100644
--- a/package/libinput/libinput.mk
+++ b/package/libinput/libinput.mk
@@ -4,7 +4,7 @@
#
################################################################################
-LIBINPUT_VERSION = 1.2.4
+LIBINPUT_VERSION = 1.3.1
LIBINPUT_SOURCE = libinput-$(LIBINPUT_VERSION).tar.xz
LIBINPUT_SITE = http://www.freedesktop.org/software/libinput
LIBINPUT_DEPENDENCIES = host-pkgconf libevdev mtdev udev