summaryrefslogtreecommitdiff
path: root/package/libinput
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2014-06-02 22:27:23 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-06-02 22:34:52 +0200
commit76dff6c63d6b4452e97295d5b512aa5381672ba7 (patch)
tree1e6341db251130387f33e648e67c1d0ced69448b /package/libinput
parent5cd1c4feb5403bb1208a6dfcc6fbf6df352d6a40 (diff)
package/libinput: new package
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libinput')
-rw-r--r--package/libinput/Config.in17
-rw-r--r--package/libinput/libinput.mk19
2 files changed, 36 insertions, 0 deletions
diff --git a/package/libinput/Config.in b/package/libinput/Config.in
new file mode 100644
index 000000000..14e4e70f9
--- /dev/null
+++ b/package/libinput/Config.in
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_LIBINPUT
+ bool "libinput"
+ depends on BR2_PACKAGE_HAS_UDEV
+ select BR2_PACKAGE_LIBEVDEV
+ select BR2_PACKAGE_MTDEV
+ help
+ libinput is a library to handle input devices in Wayland
+ compositors and to provide a generic X.Org input driver.
+ It provides device detection, device handling, input device
+ event processing and abstraction so minimize the amount of
+ custom input code compositors need to provide the common
+ set of functionality that users expect.
+
+ http://freedesktop.org/wiki/Software/libinput/
+
+comment "libinput needs udev /dev management"
+ depends on !BR2_PACKAGE_HAS_UDEV
diff --git a/package/libinput/libinput.mk b/package/libinput/libinput.mk
new file mode 100644
index 000000000..7c3e5e8bf
--- /dev/null
+++ b/package/libinput/libinput.mk
@@ -0,0 +1,19 @@
+################################################################################
+#
+# libinput
+#
+################################################################################
+
+LIBINPUT_VERSION = 0.2.0
+LIBINPUT_SOURCE = libinput-$(LIBINPUT_VERSION).tar.xz
+LIBINPUT_SITE = http://www.freedesktop.org/software/libinput
+LIBINPUT_LICENSE = MIT
+LIBINPUT_LICENSE_FILES = COPYING
+
+LIBINPUT_DEPENDENCIES = host-pkgconf libevdev mtdev udev
+LIBINPUT_INSTALL_STAGING = YES
+
+# Tests need fork, so just disable them everywhere.
+LIBINPUT_CONF_OPT = --disable-tests
+
+$(eval $(autotools-package))