summaryrefslogtreecommitdiff
path: root/package/libiscsi
diff options
context:
space:
mode:
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>2015-07-28 16:26:31 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-28 23:06:57 +0200
commit84471f1e4b531a262e8f4d2423baf5257ecd29fc (patch)
tree5d3aa1213f28ad11042615e1aca98e9b4367a210 /package/libiscsi
parent869af2ad3de46c79677699f007a5ee942aa0bb3d (diff)
libiscsi: Force configure to use gcc for LD
Fixes http://autobuild.buildroot.org/results/0a9/0a96f3654983ed2efc851522352dec43c1df0077/ [Thomas: - pass the CC variable in <pkg>_CONF_ENV instead of <pkg>_CONF_OPTS - add comment in the code explaining why we are doing this.] Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libiscsi')
-rw-r--r--package/libiscsi/libiscsi.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libiscsi/libiscsi.mk b/package/libiscsi/libiscsi.mk
index 7877cd959..adb94bdb2 100644
--- a/package/libiscsi/libiscsi.mk
+++ b/package/libiscsi/libiscsi.mk
@@ -10,4 +10,8 @@ LIBISCSI_LICENSE = GPLv2+ LGPLv2.1+
LIBISCSI_LICENSE_FILES = COPYING LICENCE-GPL-2.txt LICENCE-LGPL-2.1.txt
LIBISCSI_INSTALL_STAGING = YES
+# Force libiscsi to use gcc as the linker, otherwise it uses directly
+# ld, which doesn't work for certain architectures.
+LIBISCSI_CONF_ENV = LD="$(TARGET_CC)"
+
$(eval $(autotools-package))