summaryrefslogtreecommitdiff
path: root/package/libnftnl
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2014-01-22 15:37:27 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-01-22 21:43:51 +0100
commit5aa4e18d63f80a0db0a078f01a3241474ce12c29 (patch)
tree1564e6a692e2967a3136c3bd831348feea0173f0 /package/libnftnl
parentdf7684b5b6312ad7d723e91e890d6c48fae3b430 (diff)
libnftnl: new package
[Peter: license is GPLv2+] Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libnftnl')
-rw-r--r--package/libnftnl/Config.in18
-rw-r--r--package/libnftnl/libnftnl.mk15
2 files changed, 33 insertions, 0 deletions
diff --git a/package/libnftnl/Config.in b/package/libnftnl/Config.in
new file mode 100644
index 000000000..66d051339
--- /dev/null
+++ b/package/libnftnl/Config.in
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_LIBNFTNL
+ bool "libnftnl"
+ depends on BR2_INET_IPV6
+ depends on BR2_LARGEFILE
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ select BR2_PACKAGE_LIBMNL
+ help
+ libnftnl is a userspace library providing a low-level
+ netlink programming interface (API) to the in-kernel
+ nf_tables subsystem. The library libnftnl has been
+ previously known as libnftables. This library is
+ currently used by nftables.
+
+ http://netfilter.org/projects/libnftnl/index.html
+
+comment "libnftnl needs a toolchain w/ threads, IPv6, largefile"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INET_IPV6 || \
+ !BR2_LARGEFILE
diff --git a/package/libnftnl/libnftnl.mk b/package/libnftnl/libnftnl.mk
new file mode 100644
index 000000000..5eba0aa80
--- /dev/null
+++ b/package/libnftnl/libnftnl.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libnftnl
+#
+################################################################################
+
+LIBNFTNL_VERSION = 1.0.0
+LIBNFTNL_SITE = http://netfilter.org/projects/libnftnl/files/
+LIBNFTNL_SOURCE = libnftnl-$(LIBNFTNL_VERSION).tar.bz2
+LIBNFTNL_LICENSE = GPLv2+
+LIBNFTNL_LICENSE_FILES = COPYING
+LIBNFTNL_INSTALL_STAGING = YES
+LIBNFTNL_DEPENDENCIES = host-pkgconf libmnl
+
+$(eval $(autotools-package))