summaryrefslogtreecommitdiff
path: root/package/libnspr
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2016-01-19 23:51:11 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-01-20 00:12:41 +0100
commit86e97855724f77817749cf6a036a352ad9b99cca (patch)
tree39166cb69fefeab2209520041bf764b59baf1a05 /package/libnspr
parent91ea9331275d5074be9202a6d866f6a6a860b8d9 (diff)
libnspr: remove thumb2 handling
libnspr currently passes --enable-thumb2 if the CPU has thumb instructions. This option will pass -mthumb to the compiler. However, if an external multilib toolchain is used that has a thumb-specific variant (e.g. Sourcery), it will try to use that one. But we only copy a single variant to the sysroot, so the build will fail with: .../arm-none-linux-gnueabi/bin/ld: cannot find crti.o: No such file or directory ... collect2: error: ld returned 1 exit status ../../config/rules.mk:303: recipe for target 'libnspr4.so' failed We can in fact just remove the thumb2 handling. With current libnspr, the thumb and thumb2 options just add -marm and -mthumb. But we already pass that in our toolchain wrapper so it's completely redundant. Note that when nothing is passed, the configure script still tries to autodetect whether thumb2 is available (but doesn't do it correctly, see the error above), but in the end it doesn't use the result for anything. In other words, even if it detects that thumb2 is available, it will _not_ pass -mthumb to the compiler. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libnspr')
-rw-r--r--package/libnspr/libnspr.mk8
1 files changed, 0 insertions, 8 deletions
diff --git a/package/libnspr/libnspr.mk b/package/libnspr/libnspr.mk
index 8e58986b6..9f49eef91 100644
--- a/package/libnspr/libnspr.mk
+++ b/package/libnspr/libnspr.mk
@@ -49,12 +49,4 @@ LIBNSPR_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) LIBRARY= install
LIBNSPR_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) LIBRARY= install
endif
-ifeq ($(BR2_arm),y)
-ifeq ($(BR2_ARM_CPU_HAS_THUMB2),y)
-LIBNSPR_CONF_OPTS += --enable-thumb2
-else
-LIBNSPR_CONF_OPTS += --disable-thumb2
-endif
-endif
-
$(eval $(autotools-package))