summaryrefslogtreecommitdiff
path: root/package/libpcap
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-08-03 22:38:49 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-08-04 09:43:42 +0200
commit20cb1b90565abab87d950e7ed4d33cb2239c86dc (patch)
tree5e7d9d074e4402727379ba0d1b6c8bc85af19d25 /package/libpcap
parent01370132c10cb2d194042e08fefbc9cec8392c66 (diff)
libpcap: handle bluetooth explicitly
If bluez_utils is around then add it to dependencies so as to use it, but if it's not (for instance bluez5_utils is around) then disable it since the bluez5 API isn't compatible. Fixes: http://autobuild.buildroot.net/results/6ca/6caeb7f41ac5e14dbee49f87511af3351f6013f1/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/libpcap.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index a8c056ea3..7cf731eb8 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -20,6 +20,13 @@ LIBPCAP_CFLAGS = $(TARGET_CFLAGS)
LIBPCAP_CONF_OPT = --disable-yydebug --with-pcap=linux
LIBPCAP_CONFIG_SCRIPTS = pcap-config
+# On purpose, not compatible with bluez5
+ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
+LIBPCAP_DEPENDENCIES += bluez_utils
+else
+LIBPCAP_CONF_OPT += --disable-bluetooth
+endif
+
ifeq ($(BR2_PACKAGE_DBUS),y)
LIBPCAP_CONF_OPT += --enable-dbus
LIBPCAP_DEPENDENCIES += dbus