summaryrefslogtreecommitdiff
path: root/package/libpjsip
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-03-05 00:32:43 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-03-05 15:06:09 +0100
commit0f157eeb5efac2a32642aa84838930d14b3541cb (patch)
tree9f2b529e0ccaeb52af080cde3ad1016f51085d98 /package/libpjsip
parent6fbd0905afd3d17648366828ad55bfb114aef51a (diff)
libpjsip: new package
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Cc: Patrick Keroulas <patrick.keroulas@savoirfairelinux.com> Cc: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libpjsip')
-rw-r--r--package/libpjsip/Config.in12
-rw-r--r--package/libpjsip/libpjsip.hash5
-rw-r--r--package/libpjsip/libpjsip.mk38
3 files changed, 55 insertions, 0 deletions
diff --git a/package/libpjsip/Config.in b/package/libpjsip/Config.in
new file mode 100644
index 000000000..45387c4b3
--- /dev/null
+++ b/package/libpjsip/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_LIBPJSIP
+ bool "libpjsip"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ PJSIP is a free and open source multimedia communication
+ library written in C language implementing standard based
+ protocols such as: SIP, SDP, RTP, STUN, TURN, and ICE.
+
+ http://www.pjsip.org
+
+comment "libpjsip needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/libpjsip/libpjsip.hash b/package/libpjsip/libpjsip.hash
new file mode 100644
index 000000000..e0d3d1432
--- /dev/null
+++ b/package/libpjsip/libpjsip.hash
@@ -0,0 +1,5 @@
+# From http://www.pjsip.org/release/2.4.5/MD5SUM.TXT
+md5 f58b3485977b3a700256203a554b3869 pjproject-2.4.5.tar.bz2
+
+# Locally computed
+sha256 086f5e70dcaee312b66ddc24dac6ef85e6f1fec4eed00ff2915cebe0ee3cdd8d pjproject-2.4.5.tar.bz2
diff --git a/package/libpjsip/libpjsip.mk b/package/libpjsip/libpjsip.mk
new file mode 100644
index 000000000..ee250f5b1
--- /dev/null
+++ b/package/libpjsip/libpjsip.mk
@@ -0,0 +1,38 @@
+################################################################################
+#
+# libpjsip
+#
+################################################################################
+
+LIBPJSIP_VERSION = 2.4.5
+LIBPJSIP_SOURCE = pjproject-$(LIBPJSIP_VERSION).tar.bz2
+LIBPJSIP_SITE = http://www.pjsip.org/release/$(LIBPJSIP_VERSION)
+LIBPJSIP_LICENSE = GPLv2+
+LIBPJSIP_LICENSE_FILES = COPYING
+LIBPJSIP_INSTALL_STAGING = YES
+
+LIBPJSIP_CONF_ENV = \
+ LD="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -DPJ_HAS_IPV6=1"
+
+LIBPJSIP_CONF_OPTS = \
+ --disable-sound \
+ --disable-gsm \
+ --disable-speex-codec \
+ --disable-speex-aec \
+ --disable-resample \
+ --disable-video \
+ --disable-opencore-amr
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBPJSIP_DEPENDENCIES += openssl
+LIBPJSIP_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
+else
+LIBPJSIP_CONF_OPTS += --disable-ssl
+endif
+
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
+LIBPJSIP_DEPENDENCIES += util-linux
+endif
+
+$(eval $(autotools-package))