summaryrefslogtreecommitdiff
path: root/package/libpjsip
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2017-01-05 22:16:37 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-25 16:39:22 +1300
commitd7bc10247007e8ad7178864bcbd752a9e2ca10d8 (patch)
treea5da032711f7bdd3ecc776ebb5f2ceef4b4e5df0 /package/libpjsip
parent24a4f8a5cd2a9ab348b21ac08c339545fa3608ef (diff)
package/libpjsip: disable remaining unspecified options
There are a bunch of options that are left unspecified; explicitly disable them. The epoll case is special: the configure script is broken, and will enable it whether we pass --enable-epoll or --disable-epoll. But that's OK because we prefer epoll over the alternative (select). So we do not need to fix it. Which is nice becasue the configure.ac is named aconfigure.ac (yes, with a leading 'a'), so it does not autoreconf nicely... :-/ Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Luca Ceresoli <luca@lucaceresoli.net> Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libpjsip')
-rw-r--r--package/libpjsip/libpjsip.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/libpjsip/libpjsip.mk b/package/libpjsip/libpjsip.mk
index cb0d866e2..70dd4aa24 100644
--- a/package/libpjsip/libpjsip.mk
+++ b/package/libpjsip/libpjsip.mk
@@ -36,8 +36,29 @@ LIBPJSIP_CONF_OPTS = \
--disable-ilbc-codec \
--disable-webrtc \
--disable-opus \
+ --disable-oss \
+ --disable-ext-sound \
+ --disable-small-filter \
+ --disable-large-filter \
+ --disable-g711-codec \
+ --disable-l16-codec \
+ --disable-g722-codec \
+ --disable-libsamplerate \
+ --disable-sdl \
+ --disable-ffmpeg \
+ --disable-v4l2 \
+ --disable-openh264 \
+ --disable-libyuv \
+ --disable-ipp \
+ --disable-ssl \
+ --disable-silk \
--with-external-srtp=$(STAGING_DIR)/usr
+# Note: aconfigure.ac is broken: --enable-epoll or --disable-epoll will
+# both enable it. But that's OK, epoll is better than the alternative,
+# so we want to use it.
+LIBPJSIP_CONF_OPTS += --enable-epoll
+
ifeq ($(BR2_PACKAGE_OPENSSL),y)
LIBPJSIP_DEPENDENCIES += openssl
LIBPJSIP_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr