summaryrefslogtreecommitdiff
path: root/package/libroxml
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-08-29 08:59:01 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-08-29 08:59:01 +0200
commit134f51bf0db816027703cf6830e07fab4e798804 (patch)
tree3094d09d28e83ce65a5c706ce656136d1cf68ff4 /package/libroxml
parent779cb8be9e378158d4c3796391a514d3fb3b3b59 (diff)
libroxml: fix pthread linking issue
Fixes http://autobuild.buildroot.net/results/d18/d188bcf5c374273ffe09589f7db5a40e4c5d7bc9/ Thread handling can get disabled with --disable-xml-thread-safe, but that's a change for next. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libroxml')
-rw-r--r--package/libroxml/libroxml.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libroxml/libroxml.mk b/package/libroxml/libroxml.mk
index 9a6c97a25..f30169fe3 100644
--- a/package/libroxml/libroxml.mk
+++ b/package/libroxml/libroxml.mk
@@ -12,4 +12,8 @@ LIBROXML_LICENSE_FILES = License.txt
LIBROXML_CONF_OPT = --disable-silent-rules
+# libroxml forgets to compile/link with -pthread, even though it uses
+# thread functions breaking static linking
+LIBROXML_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -pthread" LIBS="-pthread"
+
$(eval $(autotools-package))