summaryrefslogtreecommitdiff
path: root/package/libserialport
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2015-01-29 12:35:37 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-02-01 11:43:56 +0100
commite38e894f4d9b59d9abe1b02f49bfd0b5a2dee27c (patch)
tree691d52bf96b0a0ceadb437a518687001807903fd /package/libserialport
parent083f853801afab95aee8e4e9a30c57c69f7f379a (diff)
libserialport: new package
[Peter: needs host-pkgconf, simplify pre configure hook] Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libserialport')
-rw-r--r--package/libserialport/Config.in8
-rw-r--r--package/libserialport/libserialport.mk23
2 files changed, 31 insertions, 0 deletions
diff --git a/package/libserialport/Config.in b/package/libserialport/Config.in
new file mode 100644
index 000000000..1e2935f1c
--- /dev/null
+++ b/package/libserialport/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBSERIALPORT
+ bool "libserialport"
+ help
+ Serial port access library.
+
+ This library is a part of the sigrok software suite.
+
+ http://sigrok.org/wiki/Libserialport
diff --git a/package/libserialport/libserialport.mk b/package/libserialport/libserialport.mk
new file mode 100644
index 000000000..2e57653e2
--- /dev/null
+++ b/package/libserialport/libserialport.mk
@@ -0,0 +1,23 @@
+################################################################################
+#
+# libserialport
+#
+################################################################################
+
+LIBSERIALPORT_VERSION = e31f2c6b8b8f2b7e554df911cc9a3482b99632b4
+# No https access on upstream git
+LIBSERIALPORT_SITE = git://sigrok.org/libserialport
+LIBSERIALPORT_LICENSE = LGPLv3+
+LIBSERIALPORT_LICENSE_FILES = COPYING
+# Git checkout has no configure script
+LIBSERIALPORT_AUTORECONF = YES
+LIBSERIALPORT_INSTALL_STAGING = YES
+LIBSERIALPORT_DEPENDENCIES = host-pkgconf
+
+define LIBSERIALPORT_ADD_MISSING
+ mkdir -p $(@D)/autostuff
+endef
+
+LIBSERIALPORT_PRE_CONFIGURE_HOOKS += LIBSERIALPORT_ADD_MISSING
+
+$(eval $(autotools-package))