summaryrefslogtreecommitdiff
path: root/package/libshout
diff options
context:
space:
mode:
authorJörg Krause <jkrause@posteo.de>2014-10-15 23:23:48 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-10-17 16:14:08 +0200
commit798f725cc5e16aa7b2253f608a8aff5a74498d7e (patch)
treef00a3653622f4d6cf273d95336d76d6c0ae9917a /package/libshout
parentfe0261aac1aba903716321244dab013a90918acc (diff)
libshout: new package
[Peter: fix Config.in indentation, license, needs host-pkgconf, optionally use libtheora and speex] Signed-off-by: Jörg Krause <jkrause@posteo.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libshout')
-rw-r--r--package/libshout/Config.in10
-rw-r--r--package/libshout/libshout.mk28
2 files changed, 38 insertions, 0 deletions
diff --git a/package/libshout/Config.in b/package/libshout/Config.in
new file mode 100644
index 000000000..902934274
--- /dev/null
+++ b/package/libshout/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LIBSHOUT
+ bool "libshout"
+ select BR2_PACKAGE_LIBOGG
+ select BR2_PACKAGE_LIBVORBIS
+ help
+ Libshout is a library for communicating with and sending data to an
+ icecast server. It handles the socket connection, the timing of the
+ data, and prevents bad data from getting to the icecast server.
+
+ http://icecast.org/download/
diff --git a/package/libshout/libshout.mk b/package/libshout/libshout.mk
new file mode 100644
index 000000000..1166f58d3
--- /dev/null
+++ b/package/libshout/libshout.mk
@@ -0,0 +1,28 @@
+################################################################################
+#
+# libshout
+#
+################################################################################
+
+LIBSHOUT_VERSION = 2.3.1
+LIBSHOUT_SITE = http://downloads.xiph.org/releases/libshout
+LIBSHOUT_LICENSE = LGPLv2+
+LIBSHOUT_LICENSE_FILES = COPYING
+LIBSHOUT_INSTALL_STAGING = YES
+LIBSHOUT_DEPENDENCIES = host-pkgconf libogg libvorbis
+
+ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
+LIBSHOUT_CONF_OPTS += --enable-theora
+LIBSHOUT_DEPENDENCIES += libtheora
+else
+LIBSHOUT_CONF_OPTS += --disable-theora
+endif
+
+ifeq ($(BR2_PACKAGE_SPEEX),y)
+LIBSHOUT_CONF_OPT += --enable-speex
+LIBSHOUT_DEPENDENCIES += speex
+else
+LIBSHOUT_CONF_OPTS += --disable-speex
+endif
+
+$(eval $(autotools-package))