summaryrefslogtreecommitdiff
path: root/package/libsigrok
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2015-04-10 11:49:58 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-12 18:57:13 +0200
commit18c0584f88123b02d11b0fbeb4f2b238f2baf6f8 (patch)
treee0f7c535133bb4722d04c0cd7131510ec7c4eec0 /package/libsigrok
parent330c4d01c4ff670476cc755015a833b5f963c9b7 (diff)
libsigrok: add host-doxygen dependency for C++ bindings
Doxygen is required to generate xml files required by libsigrokcxx build system. [Thomas: add host-python (or host-python3) to the dependencies when building the C++ bindings for libsigrok, since a Python interpreter >= 2.7 is needed at build time.] Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libsigrok')
-rw-r--r--package/libsigrok/libsigrok.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/libsigrok/libsigrok.mk b/package/libsigrok/libsigrok.mk
index 1e6080d09..2d044b25a 100644
--- a/package/libsigrok/libsigrok.mk
+++ b/package/libsigrok/libsigrok.mk
@@ -48,7 +48,11 @@ endif
ifeq ($(BR2_PACKAGE_LIBSIGROKCXX),y)
LIBSIGROK_CONF_OPTS += --enable-cxx
-LIBSIGROK_DEPENDENCIES += host-autoconf-archive glibmm
+LIBSIGROK_DEPENDENCIES += \
+ host-autoconf-archive \
+ glibmm \
+ host-doxygen \
+ $(if $(BR2_PACKAGE_PYTHON3),host-python3,host-python)
else
LIBSIGROK_CONF_OPTS += --disable-cxx
endif