summaryrefslogtreecommitdiff
path: root/package/libsrtp
diff options
context:
space:
mode:
authorGregory Dymarek <gregd72002@gmail.com>2014-12-12 15:42:44 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-01 11:22:52 +0100
commit10f42fa8ae8d05bf36fd5e65f0ab2a1315cab18d (patch)
tree275961004429c0bea2d0e82cd9ea2bad26ecb82a /package/libsrtp
parent31783dcf559a206bc84eac9a6529033056e5db8b (diff)
libsrtp: new package
[Thomas: - Add better Config.in help text and fix its indentation - Fix comment header in .mk file - Uncomment useful commented lines in .mk file (SITE and AUTORECONF) - Add LICENSE_FILES variable. - Add handling of static/shared libraries build/installation. - Add dependency on host-pkgconf, so that libsrtp installs its own .pc file. - Add optional dependency on OpenSSL. - Use github helper. - Remove hash file, since we're downloading from Git.] Signed-off-by: Gregory Dymarek <gregd72002@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libsrtp')
-rw-r--r--package/libsrtp/Config.in8
-rw-r--r--package/libsrtp/libsrtp.mk35
2 files changed, 43 insertions, 0 deletions
diff --git a/package/libsrtp/Config.in b/package/libsrtp/Config.in
new file mode 100644
index 000000000..ce37712f7
--- /dev/null
+++ b/package/libsrtp/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBSRTP
+ bool "libsrtp"
+ help
+ This package provides an implementation of the Secure
+ Real-time Transport Protocol (SRTP), the Universal Security
+ Transform (UST), and a supporting cryptographic kernel.
+
+ https://github.com/cisco/libsrtp
diff --git a/package/libsrtp/libsrtp.mk b/package/libsrtp/libsrtp.mk
new file mode 100644
index 000000000..5e622551d
--- /dev/null
+++ b/package/libsrtp/libsrtp.mk
@@ -0,0 +1,35 @@
+################################################################################
+#
+# libsrtp
+#
+################################################################################
+
+LIBSRTP_VERSION = v1.5.0
+LIBSRTP_SITE = $(call github,cisco,libsrtp,$(LIBSRTP_VERSION))
+LIBSRTP_AUTORECONF = YES
+LIBSRTP_INSTALL_STAGING = YES
+LIBSRTP_LICENSE = BSD-3c
+LIBSRTP_LICENSE_FILES = LICENSE
+
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBSRTP_MAKE_OPTS = libsrtp.a
+else ifeq ($(BR2_SHARED_LIBS),y)
+LIBSRTP_MAKE_OPTS = shared_library
+else
+LIBSRTP_MAKE_OPTS = libsrtp.a shared_library
+endif
+
+# While libsrtp is not using pkg-config itself, it checks if
+# pkg-config is available to determine whether it should install
+# libsrtp.pc. Since installing it seems useful, let's depend on
+# host-pkgconf to make sure pkg-config is installed.
+LIBSRTP_DEPENDENCIES = host-pkgconf
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBSRTP_DEPENDENCIES += openssl
+LIBSRTP_CONF_OPTS += --enable-openssl
+else
+LIBSRTP_CONF_OPTS += --disable-openssl
+endif
+
+$(eval $(autotools-package))