summaryrefslogtreecommitdiff
path: root/package/libssh2
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-02-14 18:38:28 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-14 22:01:49 +0100
commit3f335ed5508abe3a19e5e2106eb5339531cb4a82 (patch)
treee2783de553c2e388e7a5be1ff88c491cb9df2d8a /package/libssh2
parentc485d8a3d11616709e23ae959341a3e6c16e9dcd (diff)
package/libssh2: fix zlib library search path issues
Like for lingcrypt and openssl, help the configure script to find zlib installed in STAGING_DIR. Otherwise, It might find the one installed on the host: checking how to link with libz... /usr/lib/libz.so -Wl,-rpath -Wl,/usr/lib Fixes: http://autobuild.buildroot.net/results/93b/93b43e114f21a22f0f8b7d7dd6774c089c426cd1 Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libssh2')
-rw-r--r--package/libssh2/libssh2.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libssh2/libssh2.mk b/package/libssh2/libssh2.mk
index c9f7059bc..1a1a06f6f 100644
--- a/package/libssh2/libssh2.mk
+++ b/package/libssh2/libssh2.mk
@@ -31,7 +31,8 @@ endif
# Add zlib support if enabled
ifeq ($(BR2_PACKAGE_ZLIB),y)
LIBSSH2_DEPENDENCIES += zlib
-LIBSSH2_CONF_OPTS += --with-libz
+LIBSSH2_CONF_OPTS += --with-libz \
+ --with-libz-prefix=$(STAGING_DIR)/usr
else
LIBSSH2_CONF_OPTS += --without-libz
endif