summaryrefslogtreecommitdiff
path: root/package/libtheora
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2015-08-01 16:20:40 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-02 19:28:52 +0200
commit72f8028633e248c73a60c10c618eb454bc3b0c41 (patch)
treeee326d0fa3e284ab6e9e505412495276d4670d72 /package/libtheora
parent1688bef4c87f2da29ab66b6148d7558901be7f7c (diff)
package/libtheora: Fix dynamic linking
libtheoraenc.so needs to be linked to libtheoradec.so in order to avoid symbol 'th_comment_query_count': can't resolve symbol in lib '/usr/lib/libtheoraenc.so.1' when starting Freeswitch. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libtheora')
-rw-r--r--package/libtheora/0001-link-libtheoradec.patch21
-rw-r--r--package/libtheora/0002-fix-autoreconf.patch46
-rw-r--r--package/libtheora/libtheora.mk2
3 files changed, 69 insertions, 0 deletions
diff --git a/package/libtheora/0001-link-libtheoradec.patch b/package/libtheora/0001-link-libtheoradec.patch
new file mode 100644
index 000000000..c38d32bbb
--- /dev/null
+++ b/package/libtheora/0001-link-libtheoradec.patch
@@ -0,0 +1,21 @@
+libtheoraenc.so needs to be linked to libtheoradec.so in order to avoid
+
+symbol 'th_comment_query_count': can't resolve symbol in lib '/usr/lib/libtheoraenc.so.1'
+
+when starting Freeswitch.
+
+Patch downloaded from
+http://www.sisyphus.ru/en/srpm/Sisyphus/libtheora/patches/0
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+--- libtheora/lib/Makefile.am
++++ libtheora/lib/Makefile.am
+@@ -153,6 +153,7 @@ libtheoraenc_la_SOURCES = \
+ libtheoraenc_la_LDFLAGS = \
+ -version-info @THENC_LIB_CURRENT@:@THENC_LIB_REVISION@:@THENC_LIB_AGE@ \
+ @THEORAENC_LDFLAGS@ $(OGG_LIBS)
++libtheoraenc_la_LIBADD = libtheoradec.la
+
+ libtheora_la_SOURCES = \
+ $(decoder_sources) \
diff --git a/package/libtheora/0002-fix-autoreconf.patch b/package/libtheora/0002-fix-autoreconf.patch
new file mode 100644
index 000000000..dd3f47322
--- /dev/null
+++ b/package/libtheora/0002-fix-autoreconf.patch
@@ -0,0 +1,46 @@
+Fix broken autoreconf
+
+Downloaded from upstream git
+https://git.xiph.org/?p=theora.git;a=commitdiff;h=28cc6dbd9b2a141df94f60993256a5fca368fa54
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+
+From: Tim Terriberry <tterribe@xiph.org>
+Date: Fri, 20 May 2011 20:41:50 +0000 (+0000)
+Subject: Make autoreconf -i -f work.
+X-Git-Url: https://git.xiph.org/?p=theora.git;a=commitdiff_plain;h=28cc6dbd9b2a141df94f60993256a5fca368fa54
+
+Make autoreconf -i -f work.
+
+Patch from David Schleef.
+
+svn path=/trunk/theora/; revision=17990
+---
+
+diff --git a/Makefile.am b/Makefile.am
+index 89fd753..1783857 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -4,6 +4,8 @@
+ #AUTOMAKE_OPTIONS = foreign 1.7 dist-zip dist-bzip2
+ AUTOMAKE_OPTIONS = foreign 1.11 dist-zip dist-xz
+
++ACLOCAL_AMFLAGS=-I m4
++
+ if THEORA_ENABLE_EXAMPLES
+ EXAMPLES_DIR = examples
+ else
+diff --git a/configure.ac b/configure.ac
+index 1cbec1a..456b603 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,7 +68,7 @@ AC_LIBTOOL_WIN32_DLL
+ AM_PROG_LIBTOOL
+
+ dnl Add parameters for aclocal
+-AC_SUBST(ACLOCAL_AMFLAGS, "-I m4")
++AC_CONFIG_MACRO_DIR([m4])
+
+ dnl Check for doxygen
+ AC_ARG_ENABLE([doc],
diff --git a/package/libtheora/libtheora.mk b/package/libtheora/libtheora.mk
index 480af756b..11f9852ea 100644
--- a/package/libtheora/libtheora.mk
+++ b/package/libtheora/libtheora.mk
@@ -8,6 +8,8 @@ LIBTHEORA_VERSION = 1.1.1
LIBTHEORA_SOURCE = libtheora-$(LIBTHEORA_VERSION).tar.xz
LIBTHEORA_SITE = http://downloads.xiph.org/releases/theora
LIBTHEORA_INSTALL_STAGING = YES
+# We're patching Makefile.am
+LIBTHEORA_AUTORECONF = YES
LIBTHEORA_LICENSE = BSD-3c
LIBTHEORA_LICENSE_FILES = COPYING LICENSE