summaryrefslogtreecommitdiff
path: root/package/libucl
diff options
context:
space:
mode:
authorNimai Mahajan <nimaim@gmail.com>2015-06-26 10:19:43 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-26 20:21:53 +0200
commitda27b28838b287c263f3c7818195bc62f22967da (patch)
tree9d76d0bfa5474b780e1fc623138c7c4094ecd75e /package/libucl
parentf5aaf53de7a7cc9cf6d11bdb4709345632a39ce1 (diff)
libucl: new package
Libucl is a high performance and flexible JSON/YAML/etc. parser for C. https://github.com/vstakhov/libucl [Thomas: - remove hash file, should not be used for github downloads - rewrap Config.in help text - remove trailing white space in Config.in. - add missing host-pkgconf dependency, without which the package doesn't autoreconf properly. - fix license: it is BSD-2c, not just BSD.] Signed-off-by: Nimai Mahajan <nimaim@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libucl')
-rw-r--r--package/libucl/Config.in15
-rw-r--r--package/libucl/libucl.mk15
2 files changed, 30 insertions, 0 deletions
diff --git a/package/libucl/Config.in b/package/libucl/Config.in
new file mode 100644
index 000000000..a94701e1d
--- /dev/null
+++ b/package/libucl/Config.in
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_LIBUCL
+ bool "libucl"
+ help
+ Universal configuration library parser
+
+ Libucl is a parser and C API to parse and generate ucl
+ objects. Libucl consist of several groups of functions:
+ parser, emitting, conversion, generation, iteration,
+ validation, and utility. These functions can be used to work
+ with several formats: JSON, compact JSON, configuration
+ (nginx like), and YAML. Libucl has clear design that should
+ be very convenient for reading and writing and makes for an
+ ideal parser with high performance.
+
+ https://github.com/vstakhov/libucl
diff --git a/package/libucl/libucl.mk b/package/libucl/libucl.mk
new file mode 100644
index 000000000..3530bbe5e
--- /dev/null
+++ b/package/libucl/libucl.mk
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libucl
+#
+################################################################################
+
+LIBUCL_VERSION = 0.7.3
+LIBUCL_SITE = $(call github,vstakhov,libucl,$(LIBUCL_VERSION))
+LIBUCL_INSTALL_STAGING = YES
+LIBUCL_AUTORECONF = YES
+LIBUCL_LICENSE = BSD-2c
+LIBUCL_LICENSE_FILES = COPYING
+LIBUCL_DEPENDENCIES = host-pkgconf
+
+$(eval $(autotools-package))