summaryrefslogtreecommitdiff
path: root/package/libump
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2015-06-26 10:13:36 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-06-28 15:18:04 +0200
commit2da11575c8c317d87309f934e647bf0a72850498 (patch)
treedb2290f7b1527909db33df3a0c8c548124aa116c /package/libump
parentd00fb884e4415e09b57901b001300c6da43086e2 (diff)
libump: new package
previously, this library was a part of sunxi-mali [Thomas: add missing comment about the glibc dependency.] Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libump')
-rw-r--r--package/libump/Config.in13
-rw-r--r--package/libump/libump.mk13
2 files changed, 26 insertions, 0 deletions
diff --git a/package/libump/Config.in b/package/libump/Config.in
new file mode 100644
index 000000000..10232b3f9
--- /dev/null
+++ b/package/libump/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LIBUMP
+ bool "libump"
+ depends on BR2_TOOLCHAIN_USES_GLIBC
+ depends on BR2_arm
+ help
+ The ARMs Universal Memory Provider userspace library.
+ This library is a requirement for ARMs binary Mali driver.
+
+ http://github.com/linux-sunxi/libump
+
+comment "libump needs a (e)glibc toolchain"
+ depends on BR2_arm
+ depends on !BR2_TOOLCHAIN_USES_GLIBC
diff --git a/package/libump/libump.mk b/package/libump/libump.mk
new file mode 100644
index 000000000..65012ffd1
--- /dev/null
+++ b/package/libump/libump.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# libump
+#
+################################################################################
+
+LIBUMP_VERSION = ec0680628744f30b8fac35e41a7bd8e23e59c39f
+LIBUMP_SITE = $(call github,linux-sunxi,libump,$(LIBUMP_VERSION))
+LIBUMP_LICENSE = Apache-2.0
+LIBUMP_AUTORECONF = YES
+LIBUMP_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))