summaryrefslogtreecommitdiff
path: root/package/libupnpp
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-02-27 16:43:46 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-02-27 16:43:46 +0100
commitfb56d371639746f0d90f2e443e1b032883d57cef (patch)
tree2f961859601860b65c50d29b4db1ecd7c4f6f3ca /package/libupnpp
parenta0e44a348a922236884f4fdf2e739583d04b7a70 (diff)
libupnpp: fix libupnp detection with static linking
Fixes http://autobuild.buildroot.net/results/566/566e1510f94670d4ff642c7bfa9918c1d9ec583f/ Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libupnpp')
-rw-r--r--package/libupnpp/libupnpp.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/libupnpp/libupnpp.mk b/package/libupnpp/libupnpp.mk
index ad790f85a..853a7244e 100644
--- a/package/libupnpp/libupnpp.mk
+++ b/package/libupnpp/libupnpp.mk
@@ -11,4 +11,10 @@ LIBUPNPP_LICENSE_FILES = COPYING
LIBUPNPP_INSTALL_STAGING = YES
LIBUPNPP_DEPENDENCIES = expat libcurl libupnp
+# configure script fails to link against the dependencies of libupnp
+# causing upnp detection to fail when statically linking
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBUPNPP_CONF_ENV += LIBS='-lthreadutil -lixml -pthread'
+endif
+
$(eval $(autotools-package))