summaryrefslogtreecommitdiff
path: root/package/libv4l
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-06-12 22:07:20 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-06-12 22:26:02 +0200
commita6af4471f081a2a40f41c644cb0d54eceee3dd1f (patch)
tree1a342275a4b24cd85461a2bc3adfce86884df96d /package/libv4l
parentf16737c322971521bc8fede1e091d6a32654a78a (diff)
package/libv4l: add optional support for alsa-lib
Add alsa-lib as optional dependency to get a reproducable build. Without this patch configure logs: checking for ALSA... no configure: WARNING: ALSA library not available After this patch alsa-lib was built before libv4l: checking for ALSA... yes Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libv4l')
-rw-r--r--package/libv4l/libv4l.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libv4l/libv4l.mk b/package/libv4l/libv4l.mk
index d0a0369ee..e7a57f08b 100644
--- a/package/libv4l/libv4l.mk
+++ b/package/libv4l/libv4l.mk
@@ -18,6 +18,10 @@ LIBV4L_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99'
LIBV4L_LICENSE = GPLv2+ (utilities), LGPLv2.1+ (libraries)
LIBV4L_LICENSE_FILES = COPYING COPYING.libv4l lib/libv4l1/libv4l1-kernelcode-license.txt
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+LIBV4L_DEPENDENCIES += alsa-lib
+endif
+
ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
LIBV4L_DEPENDENCIES += argp-standalone
LIBV4L_LIBS += -largp