summaryrefslogtreecommitdiff
path: root/package/libva
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2014-07-19 12:43:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-19 14:22:55 +0200
commit64e95abe20d8468a4ba9e358d698bd81670d0887 (patch)
tree3be80cdb7b3972f8ac9b98080eaaf9259d99415a /package/libva
parent32567d1249ca2a4b5520fba03846d81090c18202 (diff)
libva/libva-intel-driver: Fix wayland-related compile errors
Fixes http://autobuild.buildroot.net/results/896/896010d8a9ef978386ea1af8e21f5999a735997d/ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libva')
-rw-r--r--package/libva/libva-0002-wayland.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/package/libva/libva-0002-wayland.patch b/package/libva/libva-0002-wayland.patch
new file mode 100644
index 000000000..e3090967d
--- /dev/null
+++ b/package/libva/libva-0002-wayland.patch
@@ -0,0 +1,26 @@
+Fixes compile error in libva-intel-driver
+
+make[4]: Entering directory `/home/br/br/output/build/libva-intel-driver-1.3.2/src'
+ CC i965_drv_video_la-i965_output_wayland.lo
+i965_output_wayland.c:31:41: fatal error: wayland-drm-client-protocol.h: No such file or directory
+compilation terminated.
+
+Patch sent upstream:
+http://lists.freedesktop.org/archives/libva/2014-July/002519.html
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+diff -uNr libva-1.3.1.org/va/wayland/Makefile.am libva-1.3.1/va/wayland/Makefile.am
+--- libva-1.3.1.org/va/wayland/Makefile.am 2014-05-09 06:28:15.000000000 +0200
++++ libva-1.3.1/va/wayland/Makefile.am 2014-07-19 11:46:01.126931242 +0200
+@@ -54,8 +54,8 @@
+
+ noinst_LTLIBRARIES = libva_wayland.la
+ libva_waylandincludedir = ${includedir}/va
+-libva_waylandinclude_HEADERS = $(source_h)
+-libva_wayland_la_SOURCES = $(source_c) $(protocol_source_h)
++libva_waylandinclude_HEADERS = $(source_h) $(protocol_source_h)
++libva_wayland_la_SOURCES = $(source_c)
+ noinst_HEADERS = $(source_h_priv)
+
+ # Wayland protocol