summaryrefslogtreecommitdiff
path: root/package/libvips
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openadk.org>2015-11-23 22:42:22 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-24 13:22:21 +0100
commitc4486e8c947e728b663eb2ac1c0286077129445f (patch)
treeb9550aee0c96f038e21d86b4463c8a238e6eaa93 /package/libvips
parent8b82f89965897e7aa65948095d0f6382f5b642ca (diff)
libvips: fix compile error for sparc64
Fixes following build error: http://autobuild.buildroot.net/results/1515f070c0fd410c681fc8306700244c34eb1635/ [Thomas: - simplify logic. - add reference to submitted gcc bug.] Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libvips')
-rw-r--r--package/libvips/libvips.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/libvips/libvips.mk b/package/libvips/libvips.mk
index d6dddc8bc..5f80b2d64 100644
--- a/package/libvips/libvips.mk
+++ b/package/libvips/libvips.mk
@@ -12,6 +12,16 @@ LIBVIPS_LICENSE = LGPLv2.1+
LIBVIPS_LICENSE_FILES = COPYING
# We're patching gtk-doc.make, so need to autoreconf
LIBVIPS_AUTORECONF = YES
+
+# Sparc64 compile fails, for all optimization levels except -O0. To
+# fix the problem, use -O0 with no optimization instead. Bug reported
+# upstream at https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69038.
+ifeq ($(BR2_sparc64),y)
+LIBVIPS_CXXFLAGS += -O0
+endif
+
+LIBVIPS_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) $(LIBVIPS_CXXFLAGS)"
+
LIBVIPS_CONF_OPTS = \
--disable-introspection \
--without-dmalloc \