summaryrefslogtreecommitdiff
path: root/package/libvpx
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2013-08-30 11:05:57 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-08 21:41:39 +0200
commitadf6511013b8921d6856f5dc0e053cdd27891244 (patch)
tree14f1ba25f8ae138743e3f3954b85883c636714d8 /package/libvpx
parentbafa8fcc6ce90553843b5c24e68de57c40f94abe (diff)
Remove multimedia subdirectory
Unless it was a group of sub-packages, packages was never regrouped by category. multimedia/ was an exception to this rule. This patch move packages/multimedia/ sub-directories to packages/. It keeps two subdirectories for gstream 0.10 and gstreamer 1.X. Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libvpx')
-rw-r--r--package/libvpx/Config.in7
-rw-r--r--package/libvpx/libvpx.mk53
2 files changed, 60 insertions, 0 deletions
diff --git a/package/libvpx/Config.in b/package/libvpx/Config.in
new file mode 100644
index 000000000..1332c564a
--- /dev/null
+++ b/package/libvpx/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LIBVPX
+ bool "libvpx"
+ help
+ A high-quality, open video format that's freely available to
+ everyone.
+
+ http://webmproject.org
diff --git a/package/libvpx/libvpx.mk b/package/libvpx/libvpx.mk
new file mode 100644
index 000000000..480f1c460
--- /dev/null
+++ b/package/libvpx/libvpx.mk
@@ -0,0 +1,53 @@
+################################################################################
+#
+# libvpx
+#
+################################################################################
+
+LIBVPX_VERSION = v1.2.0
+LIBVPX_SITE = http://git.chromium.org/webm/libvpx.git
+LIBVPX_SITE_METHOD = git
+
+LIBVPX_LICENSE = BSD-3c
+LIBVPX_LICENSE_FILES = LICENSE PATENTS
+
+LIBVPX_INSTALL_STAGING = YES
+
+# ld is being used with cc options. therefore, pretend ld is cc.
+LIBVPX_CONF_ENV = \
+ LD="$(TARGET_CC)" \
+ CROSS=$(GNU_TARGET_NAME)
+
+LIBVPX_CONF_OPT = \
+ --disable-examples \
+ --disable-docs \
+ --disable-unit-tests
+
+# This is not a true autotools package. It is based on the ffmpeg build system
+define LIBVPX_CONFIGURE_CMDS
+ (cd $(LIBVPX_SRCDIR) && rm -rf config.cache && \
+ $(TARGET_CONFIGURE_OPTS) \
+ $(TARGET_CONFIGURE_ARGS) \
+ $(LIBVPX_CONF_ENV) \
+ ./configure \
+ --target=generic-gnu \
+ --enable-pic \
+ --prefix=/usr \
+ $(SHARED_STATIC_LIBS_OPTS) \
+ $(LIBVPX_CONF_OPT) \
+ )
+endef
+
+define LIBVPX_BUILD_CMDS
+ $(TARGET_MAKE_ENV) $(LIBVPX_MAKE_ENV) $(MAKE) -C $(@D) all
+endef
+
+define LIBVPX_INSTALL_STAGING_CMDS
+ $(TARGET_MAKE_ENV) $(LIBVPX_MAKE_ENV) $(MAKE) DESTDIR="$(STAGING_DIR)" -C $(@D) install
+endef
+
+define LIBVPX_INSTALL_TARGET_CMDS
+ $(TARGET_MAKE_ENV) $(LIBVPX_MAKE_ENV) $(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D) install
+endef
+
+$(eval $(generic-package))