summaryrefslogtreecommitdiff
path: root/package/libwebsock
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-01-04 12:07:42 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-04 21:33:21 +0100
commit2967f17c5281a4ab7f85f46fd60e34d91e9c1eb7 (patch)
tree5ac0ed2bdfa3857cbae3c1a4c661f3da6250da03 /package/libwebsock
parentfe430adc2868f6317bab8e73625a0f32181b7ad7 (diff)
package/libwebsock: allow building without SSL
libwebsock can optionally use SL, and defaults to using it without checking for its presence first. Just disable SSL support if openssl is not enabled, and ensure it is built before libwebsock if it is enabled. Add a patch to fix SSL conditional build. Fixes: http://autobuild.buildroot.org/results/2c4/2c49e45667aaf2f2a59ace94885b9d4ed98038d7/ http://autobuild.buildroot.org/results/517/517bc814732f86dc6dd1a5c91148ce52ec9803f7/ http://autobuild.buildroot.org/results/951/95109c7e37aa21228bc71c69e9c66a6821f3174a/ ... Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Gregory Dymarek <gregd72002@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libwebsock')
-rw-r--r--package/libwebsock/0002-fix-ssl.patch26
-rw-r--r--package/libwebsock/libwebsock.mk7
2 files changed, 33 insertions, 0 deletions
diff --git a/package/libwebsock/0002-fix-ssl.patch b/package/libwebsock/0002-fix-ssl.patch
new file mode 100644
index 000000000..51b9b3682
--- /dev/null
+++ b/package/libwebsock/0002-fix-ssl.patch
@@ -0,0 +1,26 @@
+config: fix SSL detection
+
+The @WEBSOCK_HAVE_SSL@ is not replaced at configure time, and even if
+it was, it would be replaced by an empty string if openssl is disabled,
+thus still defining WEBSOCK_HAVE_SSL when we would not want it.
+
+Instead, rely on config.h, which is properly generated by ./configure,
+to provide the information about whether openssl is enabled or not.
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+
+diff -durN a/src/websock_config.h.in b/src/websock_config.h.in
+--- a/src/websock_config.h.in
++++ b/src/websock_config.h.in
+@@ -1,9 +1,10 @@
+ #ifndef WEBSOCK_CONFIG_H
+ #define WEBSOCK_CONFIG_H 1
+
++#include "config.h"
++
+ #define WEBSOCK_PACKAGE_STRING @WEBSOCK_PACKAGE_STRING@
+ #define WEBSOCK_PACKAGE_VERSION @WEBSOCK_PACKAGE_VERSION@
+ #define WEBSOCK_PACKAGE_NAME @WEBSOCK_PACKAGE_NAME@
+-#define WEBSOCK_HAVE_SSL @WEBSOCK_HAVE_SSL@
+
+ #endif
diff --git a/package/libwebsock/libwebsock.mk b/package/libwebsock/libwebsock.mk
index 845888306..b52293b21 100644
--- a/package/libwebsock/libwebsock.mk
+++ b/package/libwebsock/libwebsock.mk
@@ -12,4 +12,11 @@ LIBWEBSOCK_INSTALL_STAGING = YES
LIBWEBSOCK_LICENSE = LGPLv3
LIBWEBSOCK_LICENSE_FILES = COPYING.lesser
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBWEBSOCK_DEPENDENCIES += openssl
+LIBWEBSOCK_CONF_OPTS += --with-ssl
+else
+LIBWEBSOCK_CONF_OPTS += --without-ssl
+endif
+
$(eval $(autotools-package))