summaryrefslogtreecommitdiff
path: root/package/libxml-parser-perl
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2014-10-11 08:36:42 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-10-17 14:17:48 +0200
commit8e716d659b08635bba703d9ae0867d8590f6b083 (patch)
tree6571d8be16902681fede017e42430047ef9bc92d /package/libxml-parser-perl
parent841c63ce669d67481450b57f0f99b44c736d97dc (diff)
libxml-parser-perl: restore it like before perl infra
intltool uses this package, and we don't want that it depends on host-perl, but on system perl Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/libxml-parser-perl')
-rw-r--r--package/libxml-parser-perl/libxml-parser-perl.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/libxml-parser-perl/libxml-parser-perl.mk b/package/libxml-parser-perl/libxml-parser-perl.mk
new file mode 100644
index 000000000..a07f0a080
--- /dev/null
+++ b/package/libxml-parser-perl/libxml-parser-perl.mk
@@ -0,0 +1,34 @@
+################################################################################
+#
+# libxml-parser-perl
+#
+################################################################################
+
+LIBXML_PARSER_PERL_VERSION = 2.41
+LIBXML_PARSER_PERL_SOURCE = XML-Parser-$(LIBXML_PARSER_PERL_VERSION).tar.gz
+LIBXML_PARSER_PERL_SITE = $(BR2_CPAN_MIRROR)/authors/id/T/TO/TODDR
+LIBXML_PARSER_PERL_DEPENDENCIES = expat
+LIBXML_PARSER_PERL_LICENSE = Artistic or GPLv1+
+LIBXML_PARSER_PERL_RUN_PERL = `which perl`
+
+define HOST_LIBXML_PARSER_PERL_CONFIGURE_CMDS
+ (cd $(@D) ; \
+ $(HOST_CONFIGURE_OPTS) $(LIBXML_PARSER_PERL_RUN_PERL) Makefile.PL \
+ PREFIX=$(HOST_DIR)/usr \
+ EXPATLIBPATH=$(HOST_DIR)/usr/lib \
+ EXPATINCPATH=$(HOST_DIR)/usr/include \
+ INSTALLDIRS=site \
+ INSTALLSITELIB=$(HOST_DIR)/usr/lib/perl \
+ INSTALLSITEARCH=$(HOST_DIR)/usr/lib/perl \
+ )
+endef
+
+define HOST_LIBXML_PARSER_PERL_BUILD_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define HOST_LIBXML_PARSER_PERL_INSTALL_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install
+endef
+
+$(eval $(host-generic-package))