summaryrefslogtreecommitdiff
path: root/package/lighttpd
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-07-23 11:56:44 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-23 17:02:52 +0200
commita9b6c76560042cc99a545aa88dbecd25823728d4 (patch)
tree16b329e664725686eab64de85e65fcae37de121b /package/lighttpd
parentf08d626a02eb3f554885ede9a2e198e641f4f8ad (diff)
lighttpd: webdav locks require libuuid
Since 1.4.40 webdav locks require libuuid from util-linux, so make it an automatic dependency. Fixes: http://autobuild.buildroot.net/results/b14/b14484300b4acfcaa18593b097167cef14330898/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lighttpd')
-rw-r--r--package/lighttpd/lighttpd.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index 4a92a68dc..29d8634b9 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -46,7 +46,13 @@ endif
ifeq ($(BR2_PACKAGE_LIGHTTPD_WEBDAV),y)
LIGHTTPD_DEPENDENCIES += libxml2 sqlite
-LIGHTTPD_CONF_OPTS += --with-webdav-props --with-webdav-locks
+LIGHTTPD_CONF_OPTS += --with-webdav-props
+ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)
+LIGHTTPD_CONF_OPTS += --with-webdav-locks
+LIGHTTPD_DEPENDENCIES += util-linux
+else
+LIGHTTPD_CONF_OPTS += --without-webdav-locks
+endif
else
LIGHTTPD_CONF_OPTS += --without-webdav-props --without-webdav-locks
endif