summaryrefslogtreecommitdiff
path: root/package/links
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-20 18:09:01 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 14:59:44 +0100
commit5c9490459e7138f1bc4ec2d3668cc7374ea4763e (patch)
tree5bd127bae2e706353330ef0b3959e2e9e14cfc45 /package/links
parent9f7991d78c744f5c3b8358b65089ad4ccb102fe4 (diff)
package/links: add optional support for gpm
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/links')
-rw-r--r--package/links/links.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/links/links.mk b/package/links/links.mk
index def7b7590..62f91a32e 100644
--- a/package/links/links.mk
+++ b/package/links/links.mk
@@ -56,6 +56,13 @@ else
LINKS_CONF_OPTS += --without-bzip2
endif
+ifeq ($(BR2_PACKAGE_GPM),y)
+LINKS_CONF_OPTS += --with-gpm
+LINKS_DEPENDENCIES += gpm
+else
+LINKS_CONF_OPTS += --without-gpm
+endif
+
ifeq ($(BR2_PACKAGE_LIBEVENT),y)
LINKS_CONF_OPTS += --with-libevent
LINKS_DEPENDENCIES += libevent