summaryrefslogtreecommitdiff
path: root/package/links
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-06-17 16:05:49 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-06-18 13:53:43 +0200
commit69636df180e4a723b6160685b605dfbe326a0d26 (patch)
tree5e9c6c19b4394a4c450c2361f3c005d70354e3f6 /package/links
parent9019f17c6875a7411579645a8a87adf1ec6bfcf2 (diff)
links: add security fix for CVE-2013-6050
Also fix LICENSE typo. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/links')
-rw-r--r--package/links/links-0001-no-largefile.patch (renamed from package/links/links-no-largefile.patch)0
-rw-r--r--package/links/links-0002-CVE-2013-6050.patch17
-rw-r--r--package/links/links.mk2
3 files changed, 18 insertions, 1 deletions
diff --git a/package/links/links-no-largefile.patch b/package/links/links-0001-no-largefile.patch
index f3143cba0..f3143cba0 100644
--- a/package/links/links-no-largefile.patch
+++ b/package/links/links-0001-no-largefile.patch
diff --git a/package/links/links-0002-CVE-2013-6050.patch b/package/links/links-0002-CVE-2013-6050.patch
new file mode 100644
index 000000000..d85c2503c
--- /dev/null
+++ b/package/links/links-0002-CVE-2013-6050.patch
@@ -0,0 +1,17 @@
+Description: Fix integer overflow in graphics mode (CVE-2013-6050)
+Author: Mikulas Patocka <mikulas@artax.karlin.mff.cuni.cz>
+Bug-CVE: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-6050
+
+Index: links-2.7/html_tbl.c
+===================================================================
+--- links-2.7.orig/html_tbl.c 2013-11-22 01:57:29.000000000 +0100
++++ links-2.7/html_tbl.c 2013-11-22 01:58:30.000000000 +0100
+@@ -1550,6 +1550,8 @@ static void add_to_rect_sets(struct rect
+ static void add_to_cell_sets(struct table_cell ****s, int **nn, int *n, struct rect *r, struct table_cell *c)
+ {
+ int i, j;
++ if (r->y1 < 0 || r->y2 < 0)
++ fatal_exit("add_to_cell_sets: integer overflow: %d, %d", r->y1, r->y2);
+ for (i = r->y1 >> RECT_BOUND_BITS; i <= (r->y2 - 1) >> RECT_BOUND_BITS; i++) {
+ if (i >= *n) {
+ struct table_cell ***ns;
diff --git a/package/links/links.mk b/package/links/links.mk
index 6e683dd09..a7baa4c75 100644
--- a/package/links/links.mk
+++ b/package/links/links.mk
@@ -7,7 +7,7 @@
LINKS_VERSION = 2.7
LINKS_SITE = http://links.twibright.com/download
LINKS_DEPENDENCIES = host-pkgconf
-LINKS_LICNSE = GPLv2+
+LINKS_LICENSE = GPLv2+
LINKS_LICENSE_FILES = COPYING
ifeq ($(BR2_PACKAGE_LINKS_GRAPHICS),y)