summaryrefslogtreecommitdiff
path: root/package/linux-pam
diff options
context:
space:
mode:
authorNiranjan Reddy <niranjan.reddy@rockwellcollins.com>2016-03-16 17:15:35 +0530
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-04-19 23:22:32 +0200
commit8ee7c0ded2286f0decd96fe0c572b90e913a130e (patch)
treeb550f6e35ee554d4b8a5b41314b0148fbec68650 /package/linux-pam
parentdb22eb686a8e45ccefbaf87ae18ac4588abea4f5 (diff)
linux-pam: add optional libselinux and audit dependencies
This patch adds optional libselinux and audit packages to linux-pam package. Signed-off-by: Niranjan Reddy <niranjan.reddy@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/linux-pam')
-rw-r--r--package/linux-pam/linux-pam.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/linux-pam/linux-pam.mk b/package/linux-pam/linux-pam.mk
index 71c5490c7..2b94412ff 100644
--- a/package/linux-pam/linux-pam.mk
+++ b/package/linux-pam/linux-pam.mk
@@ -26,6 +26,20 @@ LINUX_PAM_DEPENDENCIES += gettext
LINUX_PAM_MAKE_OPTS += LIBS=-lintl
endif
+ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
+LINUX_PAM_CONF_OPTS += --enable-selinux
+LINUX_PAM_DEPENDENCIES += libselinux
+else
+LINUX_PAM_CONF_OPTS += --disable-selinux
+endif
+
+ifeq ($(BR2_PACKAGE_AUDIT),y)
+LINUX_PAM_CONF_OPTS += --enable-audit
+LINUX_PAM_DEPENDENCIES += audit
+else
+LINUX_PAM_CONF_OPTS += --disable-audit
+endif
+
# Install default pam config (deny everything except login)
define LINUX_PAM_INSTALL_CONFIG
$(INSTALL) -m 0644 -D package/linux-pam/login.pam \